cancel
Showing results for 
Search instead for 
Did you mean: 

Just and Advice about Using integrated USB 3.1 Gen 2 ASMedia USB 3.1 Controller

Wardogc81
Level 4
Hello,

i found something very interesting today, i have this specs Intel Core i7700K with 16GB Ram DDR4 and a 1080TI with motherboard ASUS Prime Z270 A, this motherboard have 2 USB 3.1 Gen2 Type C and A ports.

So I assumed it was the best option to use oculus Link directly on the Type C port but when the V23 Betta arrived i Started to test the Bitrate on the oculus debug tool and if i tried to use anything above 150mbps the positional tracking was broken and very stuttery, so i assumed my Video Card (1080ti) didnt have good encoding capabilities compared to RTX 20 and 30 series, and obously at 150mbps the compression artifact are very evidents and impossible to ignore.

Now with this new update that became official v23 on both Quest 2 and PC software o couldnt believe that the resolution was so good but the compresion artifacts so bad, still having issues to pass above 150 mbps, so i decided to buy a Type C adaptor to USB A port, to test all the other 3.0 ports i have including one USB 3.0 PCIE card i bought a few years ago for the Oculus CV1 and the endless USB port issues, this model if anyone is interested 

StarTech PEXUSB3S42V

I did a bandwith test and i founf that on the other 3.0 Gen 1 ports integrated it was giving me 2.4 gbps and on the 3.1 Gen 2 it was giving me 1.8 gbps, then i tested the PCIE card and it also gave me 2.3 gbps.

So, i did a test increasing the bitrate to 200 no stutter at all, i increased to 300, also no stuter at all and the image quality is perfect now, in some very rare ocation i can find some very small artifacts but only if you look for it, for sim racing this is night and day compared to the Rift S the resolution at 80HZ and 1.4 SS in the oculus software configuration looks amazing now.

If you are having issues increasing the Bitrate do your self a favor and test all the 3.0 ports you have available this changes completely my mind about the Quest 2 for PCVR, just make sure to usa a quality 3.0 USB Type C to USB A adaptor, this is the model im using right now, best thing i could do before trying to buy a better GPU.

By the way im using the Oficial Oculus Link Cable and this Adaptor connected to the PCIE USB 3.0 dedicated card just to make sure it has enough bandwith always available, but i think the other mother board port should also work. just the freaking USB 3.1 Gen 2 underperform badly on this motherboard.

Here the link to the adaptor in case any one wants to test:
https://www.amazon.com.mx/gp/product/B079K773M7/ref=ppx_yo_dt_b_search_asin_image?ie=UTF8&psc=1

Happy Gamming and welcome to the Matrix xD








5 REPLIES 5

Horis0nten
Level 4
Thanks for sharing your insights. I have the ASMEDIA 3.1 controller on my X470 motherboard aswell. But I'm having issues with the port not keeping the Quest 2 charged. Haven't really tried to push it to see if theres is also stuttering...

But according to this post and the battery drain issue, we would be better of to buy ourselves pcie cards with type-C to solve the issue.

Wardogc81
Level 4
Ahh yes I also have that issue about the headset discharge while using the oculus link, maybe the port doesnt provide enough power, using it on the 3.0 pcie card have the same discharge rate than the integrated 3.1 gen 2, something weird is happening there but the discharge rate is very slow o would have to play 8 or more consecutive hours to discharge completely while playing I think

lensmandave
Level 9
You need a PCIE card with an optional SATA power connector to keep Quest 2 charged.
Intel Core i7 6700K @ 4.5GHz. Asus-Z170-PRO MB - CORSAIR H105 HYDRO CPU COOLER EVGA GTX 1080Ti FTW3 Elite - 16GB DDR4 2666MHZ HYPERX SAVAGE.

Wardogc81
Level 4
Well I do have the pcie card with the additional power connection but is a usb3.0 it delivers a 900ma maximum maybe a usb 3.1 can keep it charged but is not a issue for me it stay alive for many hours, more that what I can play in one day haha 

R4mp4ge
Level 3
Can you please post a link to amazon or wherever with the correct pcie card?