cancel
Showing results for 
Search instead for 
Did you mean: 

Link cable not charging Quest 2?

Eurostar27
Level 3

Recently purchased a Quest 2 plus the genuine Oculus PC link cable.  Very happy with the Quest 2, and what a fantastic upgrade from my old Rift CV1, which I managed to sell.  Love the standalone feature.  From others I have spoken to, the Oculus link cable should charge the Quest 2 with the PC on . But it does not.  When I am connected to the PC for some time it comes up on Quest 2 display that the charge is getting low?  I don't think the problem is the cable, but it may be USB 3.0 port on the motherboard, an Asus Maximus VIII Hero?  Any advice please.  

8 REPLIES 8

dewthedew902
Level 5

I can give you what I think might be the reason, but I am no expert. From what I read, there are some computers that will charge well and some that will not through the same cable. It Hass to do with how the computer is built and how much power is being sent out of the USB port. 

I am not one to build computers but I was looking into it. Specifically so I could use a Oculus Link because I am an Apple user otherwise. 

from what I found when looking at different build plans, you need the right type of motherboard and the right type of power cable and interface (all stuff on the inside of the computer) in order to give the USB port enough power to function as link and to charge the headset. 

I don’t remember what website I was on but it was suggesting to not get certain brands of motherboards and stuff because it would not provide enough power to charge the headset while you play. 

hopefully that gives you a starting ground. 

I have probably put 20+ hours into googling how to build a computer for VR though. So it took me a while to find info like that. 

I can confirm that this is not true. It has nothing to do with the computer. My quest 2 was charging on my usb-C 3.1 connection, at some point it stopped charging. I bought 3 PCIE USB-C 3.2 gen 2 addon cards. Nothing changed. Factory reset the quest, it charged for 1 day on the quest 2 cable. Got a new official link cable no change. Tried it on another computer I own with a ryzen CPU and native USB 3.2 gen 2 no change. Strangely it charges fine when plugged into my battery pack without link and charges fine on a USB type-C charger. 

Actually it is very true. It has to do with amps and voltage. And you got great cards but you also have to determine if the mother board is able to carry that kind of power over from the power supply and EVEN THEN. You probably are still gunna have the battery level go down. It depends on how intensive of a game you are playing. More intense = more battery draw. So it starts to use more battery than the computer can supply. 

from a battery pack or from the wall…100% of the cable is being used to charge. With link..some of the cable is being used to transfer data so less charge. 

but even from the wall or battery pack.,.you can manage to make the percentage go down depending on what you are doing in VR. But it’s harder. Much easier with PC because the stuff is usually much more intense. 

if you don’t believe me. Plug into your pc. But don’t use it. Come back in an hour and see what the percent is at. If it’s higher…your pc was charging it. 

No, it has nothing to do with the power output. There is a whole forum post discussing the issue. Oculus support have acknowledged the issue and are looking for a solution. 

https://forums.oculusvr.com/t5/Support/Link-not-supplying-power-to-Q2/m-p/868413/emcs_t/S2h8ZW1haWx8...

EnKixHGM
Level 3

I have suffered this same issue for months thinking it was a possible Oculus update situation and waited for a fix.

I have been using an add in pcie card (BEYIMEI PCI-Express 4X to USB 3.1 Gen 2) with 2 ports known to provide enough power.  It worked fine for months, but then out of the blue it simply was not charging.  I tried replacements and still nothing.  I still do not know what caused the cards to stop providing a charge, but using my motherboard's built in 3.2 port is now working perfectly.  I have a gigabyte aorus master Z490 motherboard.

 

I would prefer to use an add in card and not stress the motherboard components, but apparently there are ways to make it work right depending on your hardware.  I do still hope for an update that will make any of the add in cards that can provide the proper amperage draw work again.

LVNDSCAPE
Level 3

AhnoldRuningman
Level 2

Some RTX cards have a C port try it I got a speed boost of 3.1 on my Speed test of the Official Oculus Cable. Was also charging while Playing I hope this works for you all. 

I once had a 2080ti and always had the quest connected to the usb C port on it (never the motherboard's supplied USBC port.  Now I have a 3080ti that does not have a usbc port on it. Now i'm having the same issue others are mentioning.  Guess I'm going to have to go the usb c-A adaptor route that i'm reading is successful for most people with the issue..... (pisses me off, as I used to have an adaptor that came with a bluetooth headset of mine, but somehow it was misplaced probably during travel.......)