cancel
Showing results for 
Search instead for 
Did you mean: 

Low Headroom in game Despite high hardware headroom

Tacrob
Level 2
Specs:
GPU: RTX 2080 TI (tried OCed and no OC) 11GB
Processor: Ryzen 2700-X (no OC)
RAM: 16 GB (3000 MHZ, dual confirmed by CPU-Z)
MOBO: B-350 Gaming Plus
OS: Windows 10 Pro

I have tried plugging directly into GPU with USB-C and plugged into MOBO with USB-3. No difference in performance.

Issue: I can be in anything, from Oculus home to Skyrim via Steam VR and at max my GPU will be at 40% (3 GB memory free), my CPU at 30% (I've checked single cores, and non of them are pushing much past 50% individually), my RAM will have 6GB still free, and my harddrive will be running at 0-5%. Even with all that, my headroom rarely goes above 50% except during loading screens where it goes to 90-95% headroom. If I adjust in game graphics there is a performance difference, sometimes of about 10%, but nothing more. Steam VR home I'm getting 10-20% headroom at default with nothing else running in the background.

I have:
1) Re-installed Oculus software.
2) Set Oculussvr.exe (or whatever it is named) to Real Time Priority and got a small boost.
3) Set SteamVRsvr (or whatever it is named) to RTP and got no noticeable boost.
4) Changed the Render Resolution in Steam VR to the lowest and put the Custom Resolution Multiplier to 100% and in the Skyrim home screen I go from 0% headroom to 50% and the rest of the game has the same gain, though it looks dreadful. I then kept the Render Resolution at the lowest setting and upped the CRM to 500% and had no performance impact but a MASSIVE visual difference.
5) I have gone into Oculus Debug tool and changed the following: 
Pixels Per Display- Tried 1 and 1.2, no difference except in Oculus home. 1.2 reduces headroom from about 50% to 20%
Distortion Curve: Tried Default, Low, and High. Did not notice a difference.
Encode Resolution Width: Tried 100, 2016, and 2748 (or whatever the highest I can go with Quest is). No noticeable performance impact on SteamVR games.
Set Adaptive GPU Performance Scale to Disabled
Set Asynch Spacewrap to Disabled

I am at a loss at this point on what to do. My hardware can do more than Link is allowing, even in Oculus home. For a point of reference, in Heaven Benchmark I get an average of 185 FPS and a score of 4665. Any ideas on how I can get Link/Steam/something to utilize my hardware better?
5 REPLIES 5

Tacrob
Level 2
Update: I OCed my CPU and there was no performance improvement. I am convinced at this point this is a bottleneck in the software and it is wildly frustrating.

heyopey
Level 2
i have exactly the same problem .  RTX 2080 Super  only using 40 to 55%
let me know if you find an answer to our problem ?

thanks in advance
🙂

ASchneiderBR
Level 4
Hey there!

Same boat here, it is kinda incredible how Oculus is dealing with us. I believe they are discontinuing the S so the Quest can be their flagship.

I was having severe reprojection (40fps) on RECOOM running a Ryzen 9 3900X and a RTX 2080ti, can you believe it?

Here's my post about it: https://forums.oculusvr.com/community/discussion/87267/huge-performance-issues-playing-games-in-stea...

Thanks

alex_mirabella
Level 0
[SOLVED!!!!!!!!!!]
Hi everyone! I've been dealing with same problems for days, was getting Insane, tried all the solutions found on the web, with, as you'd guess, 0 results. But I finally fixed the headroom problem!! It was a conflict between oculus app and steam VR. I'll explain better, hopefully will fix it for all of you too! 

first of all, I had issues with usb and display port connection. Solved it by simply unplug the device before shut down, and only plug in again after windows start and after opening oculus app. First usb, after 10 sec displayport. Quite annoying but it works. 

to solve the headroom issues follows next steps:

- Open steam VR from desktop
- On the small SteamVR window click on the 3 small lines and open settings
- on general, "render resolution" set it on custom 1336x1440
- SteamVR always on top {disabled} (don't know if it changes anything on performance but that's what I have set
-SteamVR home {disabled}

( I actually disabled all of the options, so you might try that too) 

--------------------------------

I couldn't run any games that uses steamVR, as it was really laggy and having crashes. 

Now I can play most of my games at quite high settings, I'll write down some examples so as my pc Specs: 

I found out also that I require to change settings in "oculus debug tool" to have a nice smooth experience with all games. (make sure you open the ".exe" with right click "open as administrator"

OCULUS DEBUG TOOL SETTINGS:
- Adaptive GPU performance scale: Off

- Asynchronous Spacewarp:
 Force 45fps ASW enabled 

--------------------------------

My specs:
Prebuild HP-Omen 
I7 6700K
16Gb Ram
Nvidia Gtx 1070

I play titles like:
- Project Cars 2 (everything on high settings) 
- Dirt rally 2 (preset High settings, Texture and track on Epic)
- Assetto Corsa (Highest settings)

Before I couldn't even stay in the game menu without puke my interiors ? 
Now it's super smooth and tons of fun, my god I play until morning everyday, it's like drug addiction. 

I really hope those settings work for you guys, if you'd like to know more about in-game settings let me know and I'll be more specific. 

Enjoy your oculus experience!!
Peace 

Banana21y
Level 2

Having the exact issue as OP save the solution didn't help