cancel
Showing results for 
Search instead for 
Did you mean: 

Minecraft and Windows 10

wilza7
Level 5
The challenge over the last few days has been to get Minecraft working.  Intent was Minecraft on the quest, but running using crossplay so friends on an xbox and another PC can join.  Some Google searching seemed to suggest this could be done.  There were a whole load of ways to get Minecraft running but we wanted this one with crossplay.

The sales pitch made it sound easy enough.  Minecraft Windows 10 Edition on the PC, which we already had.  The Minecraft app on the Quest, its free and only about 9MB, so easily installed.  Oculus Link running, got that sorted long ago.  Thats all you need!  First attempts got Minecraft to start on the quest.  It ran for a few seconds while doing a 'checking for updates' and then bombs out back to the home area.  For the few seconds it was running, you could look around the VR world and it looked pretty good!

Some researching later, i found at bugs.mojang.com/browse/MCPE-16946 which has lots of people with the same and similar issues.  So read through the huge long thread which gave me a few things to try.

The key bits for me seemed to be the registry key at [HKEY_LOCAL_MACHINE\SOFTWARE\Khronos\OpenXR\1] and the "ActiveRuntime" value.  at first it didn't exist at all.  I considered manually making it, but through i'd have a go at installing OpenXR first, see if that sorted it out.  Some checks said it wasn't there.  That came from the Microsoft Store and made the registry key, but made it with a value of c;\windows\system32\MixedRealityRuntime.json.  This was supposedly the wrong one.  Looking at what HDM the Microsoft OpenXR implementation supported didn't list Oculus.  Minecraft continued to drop out at the same point, so that hadn't helped.  Next was to change the value to the suggested c:\Program Files\Oculus\Support\oculus-runtime\oculus_openxr_64.json.  Still no joy.

Some more head scratching later.  i closed minecraft on the PC.  started it from the quest.  this time it was a bit different.  Minecraft started up, but this time it was a bit different.  it was Minecraft UWP.  It sat on a white and black loading screen for ages (probs 20-30 seconds).  Minecraft started on the PC in parallel.  after the very long wait, minecraft ran!  on both quest and PC.  PC showing what the quest was doing!   Success!  

A further few seconds of confusion later about how to go from Living Room Mode to Immersive Mode, and all issues seemed to be solved!  but no!  the crossplay bit isn't there.  the friends have the wrong version of minecraft to join the game, or me to join theirs.  hohum!  Thats as far as i've got for now.  wandering around in a lonely minecraft world.

thought i'd post this so anyone else attempting to get it working can see where i've been and done.  maybe someone out there knows the secret for the next bit?  have i gone the right way, or disappeared down a rabbit hole where is seems to be working as desired, but instead i'm in a this semi working dead end?

so hopefully helpful and anyone got any ideas as to what next?


3 REPLIES 3

staypuft3
Level 2
so you just started it from the quest instead of the pc?

wilza7
Level 5
yep.  takes ages to come up.  but it turns up.  like 20-30 secs.  Minecraft is now listed as an app when in the Oculus Link home area.  just use that shortcut.

i did a bit more thinking about the issue.  Khronos made the OpenXR standard.  This problematic registry setting looks to be part of the Khronos OpenXR software given the registry key location.  Issue seems to be what value should be there and who should be setting it.

Khronos can't set it, as they have no idea which HDM and other software you want to use.  There seems to be at least 3 values to go with.  Microsoft MMR, Oculus and SteamVR.

Just started using SteamVR today, so i suspect at some point having it set to Oculus will break something in Steam.  Or installing SteamVR overwrote it and i'll find Minecraft doesn't work next time its started.

Closest i can get to a solution, is whatever game/app is starting up and needing to use OpenXR, should check what HDM its going to be using and overwrite the value as needed.

jacket82
Level 2
I have come to some what the same conclusion with that every time I switch to steamvr it rewrites the openxr runtime to steamvr and it's ok for steamvr,  then I redo the Registry for oculus and minecraft , I did have it working for realms but I play more steamvr an it keeps rewriting the Registry so.. I plan  on changing the Registry And making a desktop shortcut to open Minecraft openxr and or add it too my steam library  to see if it will work, 2/7/21