cancel
Showing results for 
Search instead for 
Did you mean: 

New Quest 2 Air Link Three Dots

Bren_Kenn10
Level 2

Hello, I am having trouble connecting my Oculus Quest 2 with my PC. I connected with the application through pairing but when I hit "Launch" I see three white dots and the application on the PC has a popup "oculus isn't working correctly please see support". I have tried:

 

Restart computer

Restart quest

Settings -> Beta -> Restart Oculus Runtime

Updated latest graphics drivers

Repairing the oculus application

Checking the compatibility on the runtime .exe files

Uninstall of all oculus software, reinstall of all oculus software

 

I have seen that reinstalling windows can help but I'd like to avoid that if possible. I also had problems connecting a Rift S to the computer which is why I got the oculus quest. 

 

 

1 REPLY 1

OculusSupport
Community Manager
Community Manager

Hey @Bren_Kenn10, it looks like you've tried a whole bunch of troubleshooting already to get connected to your PC. We know troubleshooting is not near as fun as playing in VR, so we're here to help!

 

One thing we'd recommend first is checking that your PC is compatible with using Link. You can check out our article here for some more info!

 

If your PC looks like it's compatible, we'd like for you to go ahead and send our team a support ticket here along with a copy of your Oculus logs. Please make sure and include all the detail you provided in your post here!