cancel
Showing results for 
Search instead for 
Did you mean: 

No audio when using Oculus Link

Nalin
Level 4
I have no audio on my Quest headset when using Oculus Link.  These are all the things I have tried to resolve the issue:
  • Reboot PC and/or Quest and plugged things back in in many different orders.
  • Restarted the Oculus service.
  • Tried different USB ports.
  • Tried different USB cables.
  • Tried both an active and a passive extender.
  • Tried throwing a USB 3 hub into the mix just because, both as the first part of the chain and as the second part.
  • Tried with headphones plugged into the Quest and with them removed.
  • Tried toggling all the options related to sound that I could find within the software (Devices > Quest and Touch, all those sound options).
  • Repaired / reinstalled Oculus software.
  • Uninstalled Virtual Desktop Streamer app and its audio driver.
  • Changed my desktop speakers from 5.1 to stereo.
  • Attempted setting every single audio output device as default in Windows.
  • Plugged in my CV1, went through the setup, and then tried piping audio through the Oculus Rift Headphones audio output adapter.
  • Reinstalled oculus-driver.exe.
  • Opened a ticket with Oculus Support (they told me they won't support beta software, lol)
Is there anybody with the same issue who found a solution?  Or at this point is my only bet to wait a year until it stops being beta and Oculus Support actually tries to help?
EDIT: I finally got it working after uninstalling the NVIDIA HD Audio driver.
  1. On your keyboard, press Win+X > Select "Device Manager"
  2. Open up the "Sound, video and game controllers" node.
  3. Right click the NVIDIA High Definition Audio driver and choose "Uninstall device".

108 REPLIES 108

Protocol7
Level 7
Does the Quest appear as an audio output device in Windows?

Nalin
Level 4
It does not.  I'm not sure if it is supposed to.  I've heard at least one person say they don't have it.

Spuzzum
Level 9
Cas from Cas and Chary had the same issue when just using a usb-c cable, but after connecting a 5m Cable Creations active usb 3.0 cable on top of that, she had audio. Not sure why.

https://www.youtube.com/watch?v=qqz065QERsw

Nalin
Level 4
I used that exact same extender cable that she uses in the video with a 3 foot Anker cable and got no audio.  I also tried using the 3 foot cable by itself and also got no audio.

Spuzzum
Level 9
You have audio with the CV1 though, correct?

vargablood
Level 4
i have audio with the anker usbc cable, only microphone seems to be not supportet at the moment. But i had to activate it by enabling the Audio switch in the oculus pc software under quest device settings.

Nalin
Level 4
Yes, I have audio with the CV1 with no problem.

Spuzzum
Level 9
Sounds like a settings issue then. Maybe the same as what vargablood had to do, enabling the Audio switch under the Quest settings in Oculus Home(?).

CrixUK
Level 3
Try selecting a different audio output (click on speaker icon in taskbar).
for some strange reason selecting my 2d monitor as audio output sent it to the quest.