cancel
Showing results for 
Search instead for 
Did you mean: 

Not getting pop up for oculus link on quest2. I have tried multiple cables and nothing seems to work

duke8804
Level 2

I am losing my mind here. i have tried multiple cables, even the oculus link official cable. Nothing i do has the oculus link popup appear and the oculus software says my device is not connected.

Everything else seems to work though, usb debugging, and can transfers files. I can create a game and push it to the quest 2 with no issues either.

1 REPLY 1

OculusSupport
Oculus Community Manager
Oculus Community Manager

Hey there, we want to ensure we can get you back into VR with any inconvenience so let's work together to resolve this matter.

 

Please let us know if you have verified the steps below, prior to reaching out to the community:

  • Your PC meets the recommended specs.

  • Your Oculus software is up to date on both your PC and your Quest.

Once you've confirmed these requirements, you can begin using your Quest with Link. To do so:

  1. Open the Oculus app on your PC.
  2. Turn on your Quest 2 or Quest.
  3. Plug your USB 3 cable into a USB 3.0 port on your PC, and then plug the other end into your headset.
  4. A message displays in VR prompting you to Allow access to data. Select Deny. If you mistakenly 'Allow' the prompt, you must unplug your USB cable from the Quest and plug it back in.
  5. When prompted to Enable Oculus Link, select Enable to begin remote rendering using Oculus Link.

Please reach back out here, letting us know how this has helped.​​​​​​