cancel
Showing results for 
Search instead for 
Did you mean: 

Nothing works after the update

LordofScars
Level 2

After the most recent update, all I have seen from reviews are terrible comments on how it no long connects to PCs Lost library, unable to play games, air link absolutely does not work anymore. It seems as though the response has been "like we give a **bleep**! We got trailers for games you won't be able to play cause oculus sucks!" I remember how I got this new update on my Quest 2 and now it no longer allows me to do anything but sit at the home screen. I can't do anything anymore. Its a great system with this new update. I love how it was like, "hey guys, team meeting. Team meeting. Okay so everything is going smooth. People are liking the air link. the home screen is working pretty good. Great reviews guys great reviews... now How the **bleep** do we ruin it?"

 

"what if we release an unnecessary update that no one asked for that is sold like a performance update but by performance we mean it no longer performs any tasks??" 

 

"Love that energy Tom!"

 

"Thank you sir. Its...uh..I just hate the consumer so much."

 

"We all do, Tom. (silently to self) we all do." 

10 REPLIES 10

Babble244
Level 3

I've had the same issue and support had told me that they have had no other complaints about the new update...

TomCgcmfc
Level 15

deleted post, sorry.

9 9900k, rtx3090, 32 Gb ram, 1tb ssd, 4tb hdd. xi hero wifi mb, 750w psu, Q2 w/Air Link, Vive Pro

thank you I'm an idiot when it comes to these things. I actually just figured it out on my own tho lol, it was the AMD driver, I need to role it back to April

Babble244
Level 3

but yes honestly just spoke to them today and https://community.amd.com/t5/drivers-software/oculus-quest-2-amd-drivers-not-connecting/m-p/479055#M... they said they never heard of this issue

 

skwilla
Level 2

I'm having the same issue, occulus link nor air link works.. ive only been able to use virtual desktop but I like to use the Link sometimes for the better latency.. It no longer connects at all and everything is plugged in correctly.. I've tried reinstalling oculus app on win 10, and ran the tests everything seems OK but it certainly is not.. Please, if anyone has any suggestions let me know as I've not received any replies from the forums or asking for help..

DrBalls
Level 2

I have the same issue. I feel like it's server based or worse Facebook account related. Not only can I not download, view or open anything on the Quest 2 but the Windows desktop and mobile app exhibit similar behavior. I tried more factory resets than I can shake a stick at with no luck.

 

You're right, about all it does now is let me sit in the home screen and think about where I've gone wrong in life.

 

Oculus! Fix your **bleep**!

My Q2 and PC are now both on v31.1 and everything is working fine for me with Link cable, Air Link, and Virtual Desktop.  My only complaint is that 120Hz still does not perform quite as well as it did back in v29.  I realize that this may not help those with current problems but just to let you know that not everyone are having issues.  Likewise, a good flight sim buddy of mine with a Rift S and Q1 (w/Link cable) isn't having any issues either.  Good thing too since in my neck of the woods we are in the middle of a 3 day c.virus lockdown and I'm his PC support guy, lol!

 

Those with issues need to work with Oculus Support to see if they can help.  Not sure what else you can do?  Good luck and cheers.

9 9900k, rtx3090, 32 Gb ram, 1tb ssd, 4tb hdd. xi hero wifi mb, 750w psu, Q2 w/Air Link, Vive Pro

arun.calore
Level 2

Same here, since yesterday Link doesent work anymore also airlink no connection. Very upset cause i changed nothing just a faulty update maybe..is there a way to roll back?

LoganLats
Level 3

yup same here cant even use it on my pc anymore i bet they wont even give out a refund or actually help with this solution my pc doesnt recongize it on the app anymore and i actually was able to play pc games unitl about 5 months ago now it doesnt work period i dont even know what to do for help cause i have tried literally every solution out there and my computer also meets more then the recommended requirements