cancel
Showing results for 
Search instead for 
Did you mean: 

Oculus Link App Keeps Stopping

OfficialAsianMe
Level 2
Someone, please help! I've been trying for days trying to figure out and solve the reason as to why the Oculus Link app keeps stopping on the oculus quest, I have a USB 3.0 wire and port and I meet the requirements, I don't know why it keeps stopping, all It does is it goes into a black screen, then I hear a little bit of the start up a song in the Oculus Link Home and then it crashes and says the Oculus Link App stopped working, or Oculus Link App Keeps stopping! Someone, please help me! I've been dying to play some pc vr games for ages! Thanks a bunch!
52 REPLIES 52

Caesar274
Level 2

Gagahenri said:

Are you all running on AMD tech ? 



Yep, Vega 64

ROBYER1
Level 4
Nvidia user here with a 3080, same problem but Nvidia seem to have acknowledged VR issues with the latest drivers across the past 3 months which is annoying. Still not fix in sight.

potato_thief
Level 2
rx580 & 3600 user here. This works

zpurpz
Level 2
Hey all, I rolled back drivers and still get the same issue !

i7 7700k with rx590 fatboy

VD works fine but Link does not even connect !

Gaval2
Level 2
How's this for bizarre:
I've tried two 16' third party cables. After working for two weeks after Christmas my link now freezes regardless cable used within one minute.

BUT I used Sideloading with Sidequest (all over youtube on how to) to get it working wirelessly with my wifi and the damn thing is totally stable!

How the hell is wifi stable even on star wars Squadrons but the fraking fiber optic cable licks up?! HOW?!

TheGaskinator89
Level 2
rolled back to 20.10.1 from the latest driver and worked for me

MarsHForcE1
Level 2
I've had the same problem the last few weeks but I have a rtx 2070 super. After searching around on the net to find a solution some one suggested that what was causing the problem was when the headset was 95% to 100% charged with the link cable, it would cause it too start disconnecting the headset. So I started running down the battery down to 50% and then start playing with the link cable back in, I could play for several hours without the headset disconnecting but once it started becoming fully charged again I'd start getting the problem again with the headset disconnecting with the link. I've done this quite alot the past few weeks and it always seems to be the same when it starts to hit being fully charged it'll drop out of oculus link.

Victoarrrr_
Level 2


me too. hardware checks, updates, etc.. In fact, I just installed virtual desktop -- and that works!
I am also using a Radeon 580 as noted by someone above... opened a ticket with support... <sigh> it's a day old (early X-mas present) and I pre purchased a ton of Steam VR apps/games that I can't use yet..


I would recommend using virtual desktop(especially if your pc is connected via lan and your router has 5ghz capabilitys) because link straight up sucks. only problem for me is that eurotrucksim doesn't work with vd...

michaelbelgium
Level 2
I can confirm, on AMD RX480 - downgrade to driver to 20.10.1 fixed it (came from 20.11.2)

Lefthornet
Level 2
With the 21.2.2 Update, the problem is solved  🙂