cancel
Showing results forย 
Search instead forย 
Did you mean:ย 

Oculus Link Freezing Quest

Happyduckk
Level 3
So yesterday (11/22) I was using the Link for ours and I had no issues, but today any oculus link games are freezing inside the headset. The games are perfectly fine on my PC, but the headset will freeze and I'll need to power off/restart the headset in order for it to do anything again.
Anybody else having this problem? :Has anyone found a fix for this?
Thanks ๐Ÿ™‚

P.S: . I have made sure that no cables are disconnected when the freezing occurs.
        . I have a high-end PC, so specs aren't the problem
        . This has occurred with all of my Link compatible games, not just one specific game.
        . I have the recommended Anker USB cable, so hopefully that isn't the issue
155 REPLIES 155

Tylerwang
Level 2
OMG this driving me crazy as well.  I have come from 4 years of blissful plug and play no issues HTC Vive ....to this!!!  I have changed cables, USB ports, etc.  After 15 min or so it freezes.  I have reached a point where I have zero confidence each time I want to go PCVR ...and always keeping my fingers crossed if it will work.  This is NOT the way PCVR should be.  Oculus please say something.  The Quest/2 is an amazing proposition as an all in one VR headset but make it reliable please

markwest76
Level 4
After a lot of testing I came to the conclusion that the problem are the usb ports: I have a B250 MSI motherboard with on the back a set of 2 usb-A 3.1 ports and a set of 1 usb-A 3.1 + 1 usb-C 3.1; when I use my link cable on the first 2 it keeps on freezing, but when I use the usb-A port near the usb-C link works flawlessy for hours without any freeze.
I don't know why there is such a difference in the ports, maybe the first two share power management, while the one "alone" not, anyway if you can't find a working usb-A 3.0 on your motherboard I would suggest to either use usb 2.0 or buy a PCI-e usb 3.1 card...

jirikgeorge
Level 2
Hi, just want to share what seems to fix this for me: I have original Quest connected to my PC (add on card i-tec PCIE USB3.1) via USB 3.1 cable (3M USB C Monitor Cable to type C 3.1 Gen 2, 100W from Amazon) and it had the same freezing issues (frozen headset, PC running picture and tracking OK).
Tried to fiddle with my USB ports and Sata power, PCIE etc with no results and the last thing what I tried was to remove 90deg connector on the cable and connect Quest bit awkwardly but very tight(using velcro) with Cable connected perpendicular to it.
No issues so far (just around 1 hour tried so far) but seems to be related to mechanical connection of the USB (all the way from USB port in PC to Quest). USB-C might be sensitive to potition of the cable/connector and lost synchro if any issue. 

Gaval2
Level 2
How's this for bizarre:
I've tried two 16' third party cables. After working for two weeks after Christmas my link now freezes regardless cable used within one minute.

BUT I used Sideloading with Sidequest (all over youtube on how to) to get it working wirelessly with my wifi and the damn thing is totally stable!

How the hell is wifi stable even on star wars Squadrons but the fraking fiber optic cable licks up?! HOW?!


VocableEnd
Level 2

I am getting the same issue but wirelessly. any idea on what it could be? I can only play around 15/30 minutes at a time, which is rather annoying

jesse.brophy
Level 3

I had an issue with my link cable start after v25.  Another post suggested - go to TaskManager/Details/Rightclick on OVRServer_x64.exe and set it to real-time.  This resolved my disconnect issue.  Your mileage may vary but I hope it helps someone.