cancel
Showing results for 
Search instead for 
Did you mean: 

Oculus Link. USB Device not recognised, Driver Problem?

Eurostar27
Level 3

Uninstalled and re-installed Oculus software plus the PTC, and also the USB Hub and Root Hub Controllers, plus disabled Power Management. Disabled the 'Thunderbolt' in the Bios, so USB-C ports act as normal USB 3.2. ALL MB drivers have been updated, plus Nvidia, and Windows 10. Tried ALL the USB 3.2 and USB 2.0 ports using a good quality data USB-C to USB-A cable. The USB-C ports work perfect with other devices, so how can the brand new ROG Maximus XIII Hero motherboard be faulty? I have already sent a Diagnostic to Oculus support and has  got back to me and said ''This tells us that the conflict is coming from a failure on your hardware''? This has been dismissed  as no further action from Oculus. HOW can Oculus dismiss this, without any attempt to explain why, or try and come to a solution, not even to say that your technicians will investigate this further? Hundreds of these Intel 11th Gen CPU Z590 motherboards must have been sold. Are Oculus going to get a flood of problems, ones with the Quest 2 with the Link problems on these motherboards? The Oculus Link cable DOES charge the Quest 2, BUT with the error 'USB device not recognised' and then check 'Device Manager' that shows 'Oculus Device / [!] Oculus XRSP Interface' The '!' mark indicates a Oculus driver problem? IT HAS TO BE. I WILL NOT GIVE UP, I will continue to flood ALL the Forums, Facebook, et, et with this problem. PLEASE, PLEASE come up with a solution Oculus, or at LEAST try!

2 REPLIES 2

Eurostar27
Level 3

I now have an alternative fix, thanks to Oculus Air Link.  It seems to work well, and even though I can not compare with the cable Link, the quality seems to be 'on par'.    Hopefully a fix can be found with Oculus and Win 10 not recognising the USB Link, maybe with a new driver, et, but as the Air Link works well I am not that bothered.  

No idea whats going on but I have the same issue. Ive tried everything from fresh windows install to BIOS settings and updates with no luck. Air link does not work and the main reason I upgraded my PC was to play PCVR. WTF