cancel
Showing results for 
Search instead for 
Did you mean: 

Oculus Link and Air Link don't work in my Oculus Quest 2

AdriaD2103
Level 2

I've recently bought my Quest 2 around 2 days ago, and after the first time I tried using Air Link, it hasn't ever worked since.

 

It worked firstly without any problems, and was able to play PCVR with no errors. It never worked since. I turned off my Quest 2 to have dinner and when I came back and tried to use Air Link OR Link it never worked. Every time I tried using Air Link, I was stuck in the same pattern: I saw the Oculus logo, then for a split second the infinite white grid and then the screen goes black again. After a little while I see the white grid again then it disappears, and see some gray areas in the screen that are bugged.

 

I've tried basically everything there is possible to do. I tried;

 

  • Rebooting my computer
  • Rebooting my Quest 2
  • Reinstalling and repairing the Oculus app (too many times)
  • Updated and reverted my graphics card drivers (nothing worked)
  • Rebooting my router
  • Factory resetting my Quest 2
  • Rebooting Oculus through the Beta tab
  • Reinstalling the Oculus drivers
  • Also tried Oculus Link, and tried the connection test: It was saying 370 Mbps. Didn't work either.

 

It makes me think it's my Quest 2's fault and not my PC, because if there is a connection of 370 Mbps (which is enough for PCVR) it should work but I don't even get to see the panel, my Quest 2 just glitches out. I really don't know though.

 

I also know that my PC is VR ready; These are my specs.

  • Intel i5-12600K
  • NVIDIA GeForce GTX 1660 6 GB (currently using the latest drivers; 512.95)
  • Windows 10 x64

 

I am seriously lost and I have no idea what to do, will return my Quest 2 if I don't get anything that works. I already tried contacting support but they take AGES to answer and nothing has worked for me. So, if you guys experienced the same problem and were able to solve it, I would really appreciate it if you would share the solution with me.

 

Thank you!

3 REPLIES 3

joselito06
Level 2

hola, a mi me paso lo mismo y lo que hice fue:

reiniciar el quest e iniciar el programa desde el pc, luego en le quest ir a la configuracion rapida, desactivar y activar air link y ahi me reconoce la conexion.

No me funcionó...

OculusSupport
Community Manager
Community Manager

Hey there, AdriaD2103? We appreciate you for all the hard work you have done. This can be a very hefty process so please give yourself a pat on the back! We advise at this time to please submit a support ticket here, we want to be able to take a deeper look into you PC specs and see what is causing these issues. We know how much work you have put into getting your links to work, so we hope to hear back from you soon!