Showing results for 
Search instead for 
Did you mean: 

Oculus Link cable with oculus quest 2 speeds....

Level 3

Hi all


I have a Quest 2, with the official Link cable.  When i plug it into my motherboard its an Asus Z490E Gaming, I run the speed test and I'm only seeing speeds of sub 1Gbps.  Why is this the case? I see other people getting speeds into the 3Gbps.


My CPU is an i7 10700k, 3070RTX, 32GB DDR4 Ram.


What can I do to improve the speed?




Level 5

Just tested mine with v27 (Quest 2) and v26 Oculus software. Non-official USB 3 Cable. Previously got ~2.4Gbps on the USB test, now I get around 1Gbps still showing as USB 3 though. Makes no sense...


Even though link performance was better I'm having USB issues for a while now. My Quest 2 will only connect to my PC when it is in Developer Mode. As soon as I toggle the dev mode off in the smartphone app and connect to my PC I get a message "USB device not recognized". I mean it works in dev mode so I just keep it there. But it's another indicator that there are serious issues with the USB connection that need to be fixed!

I5-10600kf@5Ghz, 16GB DDR3600, RTX 2070

Which usb cable are you using 

Level 6

Unfortunately I have to chime in here.

Never had any problems with all the previous updates but now it has hit me as well 🙂

I have a Quest-1 and my USB connection always reported 1.6 Gbps

After having received the update to V.27 (directly from V.25, I never received V.26) on the Quest the connection test now reports 700 Kbps.

The texture resolution from SideQuest still works though 🙂

PC-software is on V.26 (I never use the PTC) so it is definitely the Quest-software which is to blame.

Level 3

I haven't been able to get better than 368 for the connection speed since v.25. I've tried different PCs, different cables, and even bought an Orico USB 3.2 PCI-e 3.0 x16 card to try. None of which makes any difference.

Oculus support have been less than useful as well.

You said that you have no problems with changing the texture resolution with Side Quest?? Every time I try I get booted out of Link and the two times I was able to get around it I had a vertical black border on the right side of both eyes.  Possibly due to differences between the Quest and the Quest 2...

Man, I do not envy the Oculus Support trouble-shooters here.  Not only trying to diagnose a V27 patch problem AND the possibility of interaction with problems from the previous two patches and the fact there are two different headsets involved (and HMD vs PC programming)... including coincidence and panic (people who read about the problems and think that ANY problem they are having is related to the patch updates)...whew. I do, however, envy YOUR ability to still change the texture resolution. Sigh...😣


I keep editing this post and can not get rid of and "invalid HTML" error message

No USB-C on RTX 3080 and 3090

All RTX 30xx do not come with a USB-C. 

Level 2

Will go ahead and share my Link speed experience here. 


I bought a third-party cable a little over a month ago and was getting 1.9Gbps. Couldn't get it to work on my 3.1 gen2 port, but that is a known issue with Asmedia on the Auros gaming 7 boards. Worked fine with my 3.0 intel host controllers though. A week or two ago I started to get performance issues, especially ghosting, and checked my speeds to see that they were testing at ~930Mbps. Joined the test channel and they bumped up top 1.2Gbps. Checked Win 10 update history and there were none during this periods other than Defender definitions. System wise, I couldn't determine any significant software changes that correlated with the drop in speed. Think I read there was a headset update though, to v27.


Figuring it was the cable, I bought the official Link and it showed up today. Here are the results:


Oculus App Version (

USB-C port Asmedia (Microsoft and Auros drivers) Bandwidth 586Mbps Connection USB 3
USB-A Adapter Asmedia 3.1 Gen 2 port Bandwidth 597Mbps Connection USB 3

USB-A adapter Intel eXtensible Host Controller (1.0 Microsoft) 920Mbps Connection USB 3


Oculus App Version (

USB-C port Asmedia (Microsoft and Auros drivers) Bandwidth 625Mbps Connection USB 3

USB-A adapter Intel eXtensible Host Controller (1.0 Microsoft) 1.1Gbps Connection USB 3


Read a lot of reports of people with dropped testing speeds over the last week or so. Yet to test how the Link plays, but figured I would share my experience with others. 


Edit: Performance is fine. Seems better than my 3rd party, but won't charge while playing. Though it drained on my 3rd party cable, it was slow. Probably because I am using an adapter. 

Level 7

I factory reset my Quest 2 tonight and it did not improve my link. It did definitely fix some tracking issues, but the link is still coming in (varying on repeat tests) between about 750 and 790 mbps. I didn’t even bother trying to fire up a PC game and just played some native quest (Beatsaber is an option again with the fixed tracking). I have the official cable and I don’t remember exactly what it used to come in at, but I believe it was at least the high 2’s gbps, if not over 3 gbps. 

After factory resetting the version stayed 27 I suppose right ? 

To me it is more than clear where the problem is .. the only thing that changed in my setup was Oculus Quest 2 auto updating itself from version 26 to version 27. Exactly like me a large amount of people is experiencing halving in the USB transfer speeds.