cancel
Showing results for 
Search instead for 
Did you mean: 

Oculus Link cable with oculus quest 2 speeds....

XpertXP
Level 3

Hi all

 

I have a Quest 2, with the official Link cable.  When i plug it into my motherboard its an Asus Z490E Gaming, I run the speed test and I'm only seeing speeds of sub 1Gbps.  Why is this the case? I see other people getting speeds into the 3Gbps.

 

My CPU is an i7 10700k, 3070RTX, 32GB DDR4 Ram.

 

What can I do to improve the speed?

Thanks

 

81 REPLIES 81

Nebouxii
Level 3

Update from my earlier post: 

 

So my Asmedia 3.1 gen 2 port type-c registered as a 3.0 in the test, which showed 2.0 with my third-party cable. The speeds were low at 625Mbps though. Decided to try it anyways, and it looked real ugly with some distortion. Decided to manually bump the bitrate up to 300 and it looked amazing. A bit of jitter with snap turning, but improved by lowering my bitrate to 250. Noting, my PC has a 1070ti and 17-8700k. It also held a charge.

 

This makes me question if the Oculus app simply isn't reporting the right bandwidth. Will test more tomorrow.   

 

Edit: Well, after playing a few hours today I am still having issues. Mostly with ghosting artifacts. Considering just returning the Link cable at this point. Willing to try a PCIE card, yet there is no certainty which one will work either. Very frustrating. 

Yes, it stayed on the same version after reset. 

I understand francesco_2013 but I just find it weird that my much lower card does.
Bad decision from nVidea if you ask me.

LtJamesWatts
Level 5

Now an update which I got from official support and which I've tested extensivly during the last couple of days.
You cannot imagine how much I've tested everything for you guys as well as for myself.
Frankly, fiddeling in the software and hardware.
I went with all they've laid on on me.

I can't explain every detail cause that would take too long.

What it comes down to is this and what even support admitted:

- they are trying to fix severe problems which happened during the updates (no exact details were given')
- I've tested for them the goggles without the Link cable and that works fine but I've said that the bluryness is getting worse
- then I've tested it with the Link cable and to my surprise no more disconnections but the blurryness is getting worse as well

- even on their proposition I've tested this without antivirus enabled and even in the safe mode of Win10
- I still get to hear from them that I have a unique problem but I've told them several times that they should look at the forums more cause I'm far from the only one who experiences these problems let alone the slower connections with the Link cable

So for now guys no solution yet but I won't give up.
I want to find a solution for us all.
I am already glad that they've admitted there are severe software problems.
Like I've thought from the start but apparentely its difficult for them to be able to admit that.
I don't blame support, they are probably held back from the higher ranking ones.
As it usually goes in business.

I've literally just received my Quest 2 today and been faced with the bandwidth speed issue, and I just wanted to say thank you very much for all the work you've done in finding the cause and a possible solution.

I'm really glad to hear that they've admitted to it being a software issue, as you said.

No need to thank me Lrj, I'm just a humble guy who's trying to help us all out 😉

The rule is to try to remain friendly with the support guys.
They are only doing their jobs with sometimes limited resources cause all comes from the higher ranks which I've mentioned already.

I've been in their shoes long ago and even for a long time in IT support so I know how this goes down.
They take the piss for whatever the bosses decide.

All they can do is trying to help us with sometimes limited resources.
I respect them.

Don't worry, I will find a way to solve these problems working together with them.
It just might take time.

In the meantime enjoy the VR games which you can play just on your new amazing Quest 2.
Several good games out there which don't require a Link cable.

 

As soon as I hear more I will update this post immediately and also after some serious testing once I get an update from them.

You are having problems with blurriness?  Is is the same for all content PC and headset? Yesterday I tried (per video) turning OFF the Guardian (delete History) and rebuilding the Guardian.  This is a popular "fix" making the rounds on some other forums with a percentage of people reporting that some of their tracking problems and refresh rate issues were fixed.  I remember that they were not releasing the 90 Hertz refresh until they could get the Guardian to work also at 90.  A few people have reported they were stuck on 72 Hertz after the update and doing the Guardian history delete/rebuild allowed them their 90.  I tried it thinking that with a lot of luck it may do something for the Link problem but to no avail. Am not sure how texture resolution is handled in the Quest 2. I try using Side Quest to raise the Sharpness but it no longer works for me, but someone n the Original quest has no problems with it. Might be a related issue (resolution / Blur)?  Thank you for sharing your news with us!

First off you're welcome my friend and I would like to thank all of you who share their exact detailed problems.
In the end they seem to mostly come down the same thing.

Yes I'm having problems with blurriness on the headset itself as well as when being connected with the Link cable.
This happened since the last update.

Gonna post now a new update that I got from support.

LtJamesWatts
Level 5

I'm not gonna go into detail of all the things I had to test according to support cause that would take too long.

 

For the moment nothing is mentioned about the speed but we already know that this is due to a software problem, which they've already admitted.

 

Now on to the blurriness.
It happens with and without the Link cable and is getting worse.
I've mentioned this already in a previous post.

 

They've checked my computer with a DxDiag I've sent them a while ago and I've sent them today a more recent one.

 

What it for the moment comes down to is that they are willing to sent me a replacement for the goggles so they can check if its a device problem or not.
Asked if this will be free, probably will be, but I want to make sure.
They don't work weekends so next Monday I'll get an answer and then if its free I still have to wait to get these new goggles.
For now that's the only solution so far cause they've got no clue anymore what could be causing this (their words).

 

Don't think new goggles will solve it though.
I'm still sticking to the fact that its a software problem but they keep on saying I have a unique problem even though I've mentioned to them already that lots of people have the same problem.

The guy that helps me from support is really friendly though and like I've said already he is persistent to find a solution as well.

Guess we're gonna need some more patience guys.
Still I will never give up to find a solution for all of us.
Keeping in mind that you have enough experience with a computer, know how to keep it clean software and hardware wise, no programs running in the background which you don't really need and use a cleanup program every week for example.

Ccleaner is great and even free.

vr360bln
Level 3

it is kind of usb driver compatibility problem coming with that update amok of win10 combined with the limited hardware capabilities of that tiny Quest devices. I had this problem before, with cutted down transfer speed. Changing from mb USB 3.0 port to a PCI USB 3.0 port helped (never got Link working or even Oculus adb recognized with Asmedia Drivers and 3.1x USB ports btw). After a while then problem came back with that Quest2 update that seemed to introduce 90hz. When I switched back to 72Hz on link or native, speed was fine again at 2,4 GB/s. At some point the mb USB ports worked again...but I lost trace if it was when new Oculus drivers where installed with PC App or some Win10 USB driver update....whatever what I want to say is  that for that small money a Quest2 sets you back, you cant expect everything and for future updates of that small fella. Everytime something new is introduced with Oculus updates eg. less foveated rendering more AA or gimmics like path through environment if you reach your guardian border, steals performance from somewhere else...means something you used to work perfect **bleep**s up suddenly.

 

I visited a friend who lives near equator last month. Playing around +40° was only possible for around 10 min. Then the fan inside gone mad and suddenly apps began to crash eg. population 1...I screwed down graphics and fps on minimum via adb and then at least we could use it 🙂

 

what I want to say with my legendary stories: I am glad Quests came out, maybe the only cool thing Zuckerberg ever decided to do was buying Oculus...a great step forward for VR ... finally it is getting busy someway :-). What they pumped in that device for that little money is sick, and for anyone who never did VR before it is great. But it is still no proper VR Headset with a PC tethered and a 1000 USD GPU inside and so on....one USB cable just cant replace a DP/HDMI, USB and Power line at once with same quality.