Showing results for 
Search instead for 
Did you mean: 

Oculus Link cable with oculus quest 2 speeds....

Level 3

Hi all


I have a Quest 2, with the official Link cable.  When i plug it into my motherboard its an Asus Z490E Gaming, I run the speed test and I'm only seeing speeds of sub 1Gbps.  Why is this the case? I see other people getting speeds into the 3Gbps.


My CPU is an i7 10700k, 3070RTX, 32GB DDR4 Ram.


What can I do to improve the speed?




Level 5

A regular USB3.0 port supplies about 0.9 Amps of power which is approximately what you are currently getting. That is definitely not enough power to charge the Quest 2 headset to prevent it from draining quickly during use. Some USB 3.0 ports are also dedicated to charging devices and these ports supply up to 1.5 Amps of power. Try looking at the manual of your motherboard and look for this dedicated USB 3.0 charging port. Hopefully, your motherboard has one.

Level 15

Maybe make sure you fully take your headset off when you run the usb speed test.  I get much less when I just move it up on my forehead.  Also, you may need to run it a couple of times to get a good reading.  Also make sure your motherboard usb 3.1 gen2 type-c port has the latest win10 driver updates (mine is 16/11/2020).  With my official link cable with my Q2 and asus maximus hero xi I get 2.5Gbps.


Funny but I actually get faster usb speed with this port than I do with a dedicated Startech sata powered usb 3.1 gen2 pcie card that was recommended to me in this forum.  I only get 1.8Gbps with that one.


Oh well, at least I now have a couple extra usb type-c ports, lol!

9 9900k, rtx3090, 32 Gb ram, 1tb ssd, 4tb hdd. xi hero wifi mb, 750w psu, Q2 w/Air Link, Vive Pro

Level 3

not sure if thats still for interest here, but I found a workaround which works stabil here for about one week now.


Try to switch an USB 3.0 Hub between link cable and USB 3.0 on motherboard. Connecting Quest2 directly to PC USB 3.0 port lets it appear as USB-Composite Device in Device Manager Tree View (check this nice cheat sheat if you are interested in Windows USB Management ). With this direct connection I had this **bleep**ty 1 GB/s and permanently disconection issue after latest Oculus updates.


Using the USB Hub registers the Quest via a Generic Hub and the connection stays stable. Speeds ranging here from 2.2 GB/S on my desktop with an 4 year old Aorus Gaming 3 MB to 2.8 GB/s using the usb c port on the RTX2060 of my XMG Core notebook... (btw I use Anker® Ultra Slim Extra Light 4-Port USB 3.0 Hub )


Same on both computers without hub no stable connection possible or it is so slow my feet sleeping away....with hub perfect! The drivers used for registering the generic usb hub seem to be quite new (see screenshot) Microsoft 22.04.21 ... I think the Quest2 needs those but does only get that old composite device drivers by direct connection after that last updates....








Its been calm in this thread but its not over yet.

I was waiting for my new Ocullus Quest 2 and I got it last week but I have been sick.
Will test this all on Friday the 7th of May.
I will also keep support up-to-date about this.

I personally manually updatet the generic USB drivers, then did another Windows Update (which I do often before it suggests so, ran Driverbooster 3 Pro but most programs were up-to-date yet (tend to keep my PC clean).
Ran ccleaner Pro the clean up everything and my antivirus Avast Premium Security had its scan.

So in short I did all that I can do and this Friday I'll test everything in detail.
Support is already aware of this and promised to give them feedback but that counts as well for you guys.

Nice extra/add-on vr360bln thumbs up for that if the system will let me cause for now Kudos don't seem to work.

Keep you all posted 🖖

Level 5

Another update guys which I've just sent to support.


"All software from the app on the phone as well as on PC and on the goggles is up-to-date.
Also as every program on my computer and nothing is running in the background which isn't necessary.

The Link cable seems to do its job and works stable with the recommend speeds.

The Link cable is directly connected to my GPU.

So here are my remarks hence questions:


- why do the graphics look so blurry with games installed on the headset and others on my PC through the Link cable (all official games bougth from you guys)?
- I'm running everything on 90 Hz so could this be a problem in the software or am I using the wrong resulotion settings in the Oculus program on PC?


I'll attach another DxDiag for you to look at and I hope you can take the time to read in detail everything I already shared in the previous ticket with your colleague.
Will save us a lot of time to test things which have already been tested numerous times before.

Thank you in advance."


Now wait and see what the answer will be.
You know I never have to wait long to get an answer 😉


P.S.: For some weird reason, doens't happen always though, is that it seems like the text I see in games is shivering but like in a burning sense.
Very weird.

Level 5

Wanted to give you guys an updated but my post always gives HTML problems 😞

Level 2

On the current Beta software I get 3.0 gbps and when I take it out of beta I get 2.4 gbps. A few reversions ago I was only getting 1.3. It doesn’t seem to matter, link is wildly inconsistent. 

Level 3

Been having this problem with my Quest. Tired using a JOTO USB 3.1 cable, and then ordered the offically recomended Anker USB 3.1 cord to test with. It always shows in the Oculus app as USB 2.0, with a speed of 358mbps. Tried a bunch of different USB ports (all of which are 3.2) along with trying out a hub just for fun. Nothing seems to work.

Level 5

No idea why but I stil have the same problem to post due to HTML giving a problem.

Had an interesting update though.

Strange that a short message works.