cancel
Showing results for 
Search instead for 
Did you mean: 

Oculus Link cable with oculus quest 2 speeds....

XpertXP
Level 3

Hi all

 

I have a Quest 2, with the official Link cable.  When i plug it into my motherboard its an Asus Z490E Gaming, I run the speed test and I'm only seeing speeds of sub 1Gbps.  Why is this the case? I see other people getting speeds into the 3Gbps.

 

My CPU is an i7 10700k, 3070RTX, 32GB DDR4 Ram.

 

What can I do to improve the speed?

Thanks

 

67 REPLIES 67

Howie_Doodat
Level 7

The recent updates have just eviscerated the link capabilities for pretty much all of us (I can’t verify that it’s not the case for everyone). So...you can trouble shoot away, but we’re basically just hoping for a patch. My link has been unusable for about 2 months now (since whenever v25 came out), after several months of it being perfect fine. I’m playing the same games still, same gear, etc 

Wow, thats terrible. I can confirm im on v27.

Guess ill just have to wait.

Eldraad
Level 4

There is a problem there. I was on V26 this morning and saw a video about usb link problems with V 27 and sure enough when I put my headset on again I was now on V27.  This Morning On V26 my 3rd party USB cable tested at 2.5 Gbps... it now tests at 1.7 Gbps after the V27 update. The link quality is blurry and raising the resolution only causes jitters now.  Steam VR reports an error with every steam vr game I launch from oculus. As I bought the Quest 2 to replace my Rift S and It WAS working very well when they brought the Link out of beta I have had a great time with it.  Today for the first time I had to remove the headset due to eye strain caused by the blurry visual.

Oculus/Facebook WILL eventually fix it (month?) or maybe someone will find a workaround. But from what I have seen reported, your bad speed is a software/firmware problem and ONLY Facebook can fix it at this time.

(This is a re-post of one that blinked out of existence at birth)

It is possible that this was a problem in an earlier patch (Side Quest Texture resize no longer works since V25) but I didnt get much gameplay on 25 and 26 having moved to native quest 2 games for awhile.

LtJamesWatts
Level 4

Hi XpertXP,

Try connecting your official Link cable to your GPU instead of your motherboard.
Also make sure you have the latest software on your smarthphone, PC and your headset.

If needed uninstall the Oculus software on your PC and download the latest version.
You might lose all your save games but not your games.
Think the most important thing here is that your Link cable works.

Make also sure when you test it that before you install the latest Oculus software on your PC that your antivirus, windows defender and maybe even onedrive is disabled completely.

Also make sure that no other overclocking and optimizing software is running in the background.
Keep your startup and background processes to a minimum.

I presume that you reboot your PC regularly, turn it off completely when not using it?
Also that you have a decent enough fast connection to internet?

Best regards,


LtJamesWatts

P.S.: Just trying to help out from my own experience.

Thanks for the help with this.

The GPU doesn’t have a USBC port. I used the port on the motherboard as well as the one on the case, Lian Li 011 Dynamic.

The only thing I haven’t tried yet is checking for software updates for the Oculus app, I assumed it just ran them automatically when needed. 

XpertXP
Level 3

Also im running version 26 on my PC, cant seem to locate a version 27 or a way to update. 

Give me a link towards the exact GPU you have.
I have an RTX 2060 Super and even mine has a USB-C port.

Never heard of your computer case before, looked it up but I don't see anything relating why this would give a problem.
I would like to know how many Watts your power supply has.

Keep in mind that not all software updates automatically unless its set to do so.
Usually its set to automatically though.
Like I've said in my previous post it might be necessary to uninstall, reboot and then reinstall the software again on your PC.

 

Also warned you about the possibility of losing save games, so don't blame me afterwards.
The same thing happened to me.

I'm only trying to help you out and like to do so but I can't make miracles happen.

I hope you also kept in mind all the other things I've told you to do about not running unnecessary programs in the background.

Also if needed, cleanup your PC with Ccleaner, good program and there's a free version.
I've been using it for years and was so happy about it that I've bought the Premium version.

Just a suggestion.

I'll try to check back asap to your reply but keep in mind I have Corona, really short-breathed and always very tired so I need my sleep.

Same here but maybe some of us users need to wait for the update and that it depends on the country you live in.
Of what I've read of the update though that it is not mentioning anything about solving a Link cable connection.

So for now try to do what I've asked you to do.