cancel
Showing results for 
Search instead for 
Did you mean: 

Oculus Link not Working

I had a USB 3.0 cable to connect my Quest 2 to my windows 10 PC but that didn't work, so I bought a new cable from Anker and I tried that but it still didn't work. The Oculus PC app for some reason won't find my Oculus at all. I've tried every solution the internet has to offer but it still wouldn't work.

4 REPLIES 4

Cylotron
Level 3

CableCreation has a 16ft Extension cable that I paired with that 3ft Anker cable Amazon sells. Both items specify they work with Oculus and yes, together they work just fine.

That $79 Oculus Link cable never worked properly for me and I ended up having to return it.

     Hello! This has also been a problem for me. Fortunately, I know the solution. Oculus link works only with certain supported windows pcs. Usually the problem has to do with your graphics card and/or your processor.

     So the good news is that there is a chance you can get oculus link to work. The bad news is that you either have to buy a new graphics driver, processor, or a new pc.

     I think your best bet would be to just throw your pc in the trash and get a newer windows pc. This is because it is quite a complicated process to remove your graphics card or processor and replace it. Also most graphics cards cost about as much as an actuall pc. Most range from about $300 to $1,000 dollars, and processors are about the same. Honestly I think that even if you can afford a new graphics card or processor you'll probably have about as much trouble getting it installed as you would have trying to juggle 3 sharp flaming axes.

     So unless you are a juggler, I think you should just buy a new pc. However, before you do that, you should check your pc's system info to see if it matches the oculus link requirements. It is a lengthy process, and though there are easier methods, they will probably not give you all the information you need.

     Once you open the oculus link requirements page, leave the tab open and press the following 2 keys together: Win + R. Win is the windows key. Doing this should bring up a run prompt. in the open field on the run prompt type in "msinfo32" without quotes. If you do not have a keyboard with a Win key on your keyboard do these next steps instead of the previous ones. If you do have a Win key skip these and move on to the next paragraph. Click the "Type here to search" field on the left side of your taskbar. Type in System Information. Click the thing named "System Information" with a computer icon. It should be the first thing that pops up. When you are done with that move on to the next paragraph.

     You should now see a menu with lots of information about your pc system and more. You can use the search field in the System Information app to search for what you need. Follow these steps in order:

 

1.Search processor. It should

be highlighted after searching. Your processor must be at least  Intel i5-4590 / AMD Ryzen 5 1500X. If it is a less version than that you must either get a newer pc or a new processor.

 

2.Search display and the name of your graphics card should be highlighted. Go to the Oculus Link Requirements website and look at the table under "Supported GPUs for Oculus Link." If your GPU does not patch a supported GPU in that table then you need to get a newer pc or graphics card.

 

I hope I have helped.

     -squeakingdandeelion

 

I know. The name is weird.

sacolton
Level 2

If your PC is compatible with OQ2, then the problem is the Oculus PC app.  Uninstall it and re-install.  Also, I found when my AirLink/Link can't connect to my PC, it's because SteamVR is messing up.  Uninstall SteamVR and re-install fixed the issue for me.

 

Good luck!

Oh, I went through the whole uninstallng/re-installing & updating process. I even had them replace the Link cable for me once before I finally returned it the 2nd time. Even tried on 3 different systems.

I did get it to work fine sometimes..  but every now and then, it would do that 'disconnected' & 're-connected' b.s. It was enough for me to call it quits with the cable. Ever since switching to the "CableCreation/Anker" cables I listed above, have not had any issues since.

I'm not going to bother with a Link cable again personally. Although if it works for other people, cool!