cancel
Showing results for 
Search instead for 
Did you mean: 

Oculus Link with cable

Centerlink
Level 2

Im trying to use Oculus link with a cable, it has prevously worked before but now isnt. when i plug the headset into my PC while on the connect your headset page, the continue box quickly flashes blue then blacks out again, so the PC is picking my headset up but the oculus app isnt detecting it? when i put the headset on i get the option to allow the PC access to the headset but that still does nothing. my PC detects the HMD but the Oculus aplication doesnt detect it.

 

1 ACCEPTED SOLUTION

Accepted Solutions

Centerlink
Level 2

i have fixed the problem thanks to Oculus support! you have to disable air link in both the headset and the Oculus software.

In the PC application, navigate to Settings → Beta in the PC app and disable the Air Link toggle. Then, put on your Quest 2 headset, navigate to Settings → Experimental, and disable Air Link.

View solution in original post

7 REPLIES 7

OculusSupport
Oculus Community Manager
Oculus Community Manager

Hello there, thanks for reaching out to us. We see that you are experiencing linking issues. We're here to help! If you haven't done so already, let's try rebooting your device. To do so, click here to follow the troubleshooting steps.

 

We can also try alternate USB ports for the Link cable, especially after removing any non-Oculus USB devices. Please see the instructions below:

  1. Disable USB Selective Suspend Setting:
    1. right-click Start
    2. click Power Options
    3. click Additional Power Settings
    4. click Change plan settings
    5. click Change Advanced Power Settings
    6. find USB Settings
    7. make sure that Selective Suspend Setting is set to Disabled, not Enabled
  2. Ensure that USB power saving settings in Windows Device Manager are not enabled for your USB ports:
    1. right-click the Start button and open Device Manager
    2. find your USB ports
    3. right-click and select Properties
    4. go to Power Management
    5. make sure that options to save power are deselected (please note that it is normal that some of them will not have any checkbox for power saving settings).
  3. Try uninstalling and reinstalling the Oculus software through the add/remove programs

Let us know if this information was helpful. We look forward to hearing from you. 

 

Thanks! 🙂

Hiro_Protag0nist
Level 13

Yeah, getting the same issue here. Tried 2 different cables and 2 PCs. No longer getting the Link message pop up.

 

Have done steps 1 and 2, not 3 - hoping you can fix this via a software update.  

Will try my other Quest 2s on Monday.

Centerlink
Level 2

i have fixed the problem thanks to Oculus support! you have to disable air link in both the headset and the Oculus software.

In the PC application, navigate to Settings → Beta in the PC app and disable the Air Link toggle. Then, put on your Quest 2 headset, navigate to Settings → Experimental, and disable Air Link.

View solution in original post

Pixie40
Level 10

Yeah, Air Link and Oculus Link are mutually exclusive for some reason. If Air Link is enabled in the headset or desktop (especially headset since the desktop disables Air Link if not used every day), then your Link cable can only be used for charging. Which is odd? I suppose there's a reason for this behavor, but I don't know what it is.

Lo, a quest! I seek the threads of my future in the seeds of the past.

Hiro_Protag0nist
Level 13

Well, I'm sure this wasn't a thing about 2 weeks ago - I've been using Air Link and cabled since Air Link was introduced.

 

Thanks @Centerlink  👍

Pixie40
Level 10

It's been a thing since Air Link was introduced. I've always had to disable Air Link on both the headset and PC to use my Link Cable for more then just charging.

Lo, a quest! I seek the threads of my future in the seeds of the past.

OculusSupport
Oculus Community Manager
Oculus Community Manager

Hey Centerlink, we are excited to hear that your matter has been resolved and we appreciate you sharing the knowledge to the community as well.