cancel
Showing results for 
Search instead for 
Did you mean: 

Oculus Quest 2 Headset Not Recognized by Oculus Link

AntErm17
Level 2

Hi, I just downloaded the Oculus Link app on my 8-10 year old laptop.  I get to the point where Oculus Link asks me to connect my Oculus Quest 2 headset, but when I connect the headset to my computer using the charge cord (USB-C) that came with the headset, which is plugged into an adapter (USB-C to a USB-A) that plugs into any of the four USB ports on my laptop, it won't recognize that the headset is plugged in.  I am assuming this is because all four USB ports on my laptop are 2.0 ports (?)  My laptop does not have any USB-C port.  It does have an HDMI port.  Is there a solution for this?

 

Can I somehow use the HDMI port on my laptop instead (if there is even an adapter that allows this)? Is there another adapter that I can buy that allows me to use the 2.0 ports on my laptop?  Or do I need to replace my 2.0 ports with 3.0 ports on my laptop?  (If this is an option, how do I do this?)  Can I connect via bluetooth instead?  I tried this, but it didn't seem to work.  

 

Any help someone can provide would be greatly appreciated!

 

 

8 REPLIES 8

deR4Fa
Level 2

I Have stumbled on something very similar. I am trying to connect my Quest II to my Work Laptop ( development purpose in Unity). The laptop (with intel UHD 630 ) has 3.0/3.1 ports and the cable I am using has been tested for PCVR Gaming on my personal computer, so no issue here ( GTX 1070). I think it may be a minimum req. thing,,

Have you managed to connect your headset? 

jonah.falcon.7
Level 3

Same thing happened while playing a game on my desktop PC. Suddenly the PC link or Oculus has "malfunctioned".

Howie_Doodat
Level 7

What graphics card do you have? 

Also, there’s no HDMI adaptor that will work. HDMI (especially the version of HDMI as old as yours) doesn’t have nearly enough bandwidth for VR. It’s possible that a USB adaptor could work for you, but before you bother I’d check out what graphics card you have. If it’s not a dedicated GPU, no adapter will help you. 

Also, any time you use an adapter, your quality will be restricted to the weakest component involved. So if you have a USB-C cable with an older USB-A adapter, you’ll only get the bandwidth and charging capabilities of the adapter. 

Hmmm.  I may be in trouble based on what you have compared to what I have.  I have not tried connecting again as I don't have a solution, but I'm hoping that Howie_Doodat below is onto something.....

Have you already downloaded the Oculus Link app and successfully connected your headset to your computer?  Meaning, the Oculus Link app shows that it has been connected?

So when I went to Task Manager and clicked on the Performance tab, there is no GPU listed.  I'm assuming that means I don't have a graphics card.  Is there another way to verify this?  If I don't need a graphics card, do I need to install one?  How do I go about doing so?  Is it even worth it?  

 

I don't want to play any games on my computer.  I just want to get the Oculus Link app set up properly so I can use SideQuest.  As I understand it, you have to download and successfully set up the Oculus Link app as well as the SideQuest app (this one I've already downloaded).  

 

Based on my search in Device Manager, it shows that I have a 3.0 USB port.  Also, I had purchased an adaptor on Amazon a little over a week ago, which is what I used to connect my headset to my laptop since my laptop doesn't have a USB-C port.  

 

If you can provide any guidance, I'd really appreciate it.  Thanks!

Howie_Doodat
Level 7

If you don’t know if you have a dedicatee card, chances are you don’t. I believe you could look under your drivers and see, or look up your computer model. 

As for side quest, I’d imagine that any computer will be good enough to load games onto the quest from side quest, but there’s no need to buy the recommended link cable for that. As for games that run via your computer and display on your headset (I think some side quest games are like this?), that won’t be an option without a good computer/card. 

In MY case, the Quest 2 and Windows 10 decided that they were no longer compatible, and says that my device is malfunctioning.