cancel
Showing results for 
Search instead for 
Did you mean: 

Oculus Quest 2 stuck in getting the latest update while initial setup

Rathod_13
Level 2

I am setting up my new Oculus Quest 2 and it is stuck at “Getting the latest software update” in the initial setup after connecting to wifi. Support team is saying this is known issue and hard reset the VR controller and re-install the app. Didn’t work!

 

What next?

1 ACCEPTED SOLUTION

Accepted Solutions

TheLegend27
Retired Support

Hey everyone! Engineering is aware of this issue, and is currently working on a fix. We don't have a specific timeline on when the fix will roll out, but we appreciate your patience as the team works on it! I'm going to be locking this thread, so that we can keep the reports all in once place in the known issue thread that was floated to the main Support board not too long ago.

Technology, at a certain level of sophistication, is indistinguishable from magic. - some wise guy or something probably

View solution in original post

18 REPLIES 18

Erik_Stays_Up
Level 2

I'm at the same place. Been trying to update for 3 hours now.. any luck? 

ishdemon10
Level 4

Same here.. It seems it's bugged for every new user/first time setup. I have changed wifi 3 times & even did factory reset. Nope. Still same.. Looks like some kind of server/cdn issue with oculus. I was going bonkers.. I thought I got a bad batch of quest or something.. 

ishdemon10
Level 4

Bro, you are from India? Is it specific to Indian region🤔

Nutttyy
Level 2

same problem man, support team said the same thing

StellaLT
Level 2

just talked with the support and they said they are fixing it and hope it can be solved within 24 hours.

 

Let's hope they will. I thought my quest2 is bricked for sure. 🙏

SpeedyBus
Level 2

Same Issue. The team didn't give me an exact time. The email states 3-5 business days with an update into their investigations. I've tried so many things. We should get compensated for this.

kazkingdead
Level 2

I have the same problem. Update downloads are stuck at 0%. Hardware reset didn't make sense either.

Orion_Werefox
Level 3

Same issue here, factory setting didn't help, rebooting didn't help, pairing it with my phone did nothing too