Showing results for 
Search instead for 
Did you mean: 

Oculus Quest Appears on PC but Won't Show any Folders on PC

Level 16
When I connect Quest to PC it just shows up as a portable device "quest" in device manager and Windows Explorer. The folder is empty on windows. Currently what I have to do is go to the Phone APP and toggle developer mode OFF then ON again for the message to appear in the headset about accepting the connection. I have updated the drivers (see support message below) but each time I need to connect it requires this dance with the phone app. This is pretty unfeasible seeing as it's not my phone and I don't always have access to it. Any suggestions please?

If your Oculus Quest headset is not appearing as a drive on your Windows PC:

  • Make sure that you use the included USB cable from your Oculus Quest package.
  • Make sure that you select Accept in VR from your headset to allow your computer to access files on your headset.
  • Update your device driver:
    1. From your PC desktop, right-click on This PC or My Computer.
    2. Select Computer.
    3. Select Manage.
    4. Select Device Manager.
      • If you can't see the Manage option, just select Device Manager directly.
    5. Click the next to Oculus Devices or Portable Devices to expand your options.
    6. Right-click on Quest and select Update Driver.
    7. Select the Browse my computer option, then the Let me pick from a list option.
    8. Select MTP USB Device and then select Next to complete the update.

System Specs: ASUS NVIDIA RTX 3090 TUF GAMING OC 24GB , i9 9900K CPU, 16 GB DDR 4 RAM, Win 10 64 Bit OS.

Level 13
Struggled until i found this - had to turn dev mode off then on to see anything in my Quest folder on PC - thanks.

Level 4
Oh...why on earth do we need to disable developer mode to access files on the device?  

Level 3
For me it was catching the Allow message box in the Quest at the right time.

Level 4
Today I ran into this problem. Previously file access worked fine. Today it did not.

I have developer mode activated. 

What I had to do was disable developer mode.
Accept the MTP request in the Quest.
Then after re-enabling Developer Mode. MTP worked fine. 

The accept MTP dialog did not show up with developer mode enabled for some reason. 

Level 2


Level 3
Thanks! This is annoying, hopefully it gets fixed soon.

Level 3
cmd line 'adb devices' via adb made my folders discoverable, no needs to disable developer mode.

Level 2
Wow! I would of sworn for a good hour if I had not seen your post! Thanks! FYI same on mac. The Android File Transfer app gives you the error message and if Dev mode is enabled, no prompt will ever be triggered on the head set. Took my phone and the second dev mode was disabled, boom, prompt screen showed up...

Level 2
So annoying. In my case I have to turn dev mode off every time; if I plug it in with dev mode on it doesn't show the storage at all.