cancel
Showing results for 
Search instead for 
Did you mean: 

Oculus Quest Home 'Sorry, something went wrong - please try again later'

TheAudi
Level 3
Had my oculus quest around 3-4 days now, and since I've bought it I haven't seen the home work once.
I've just done a factory reset in the hopes it would resolve the issue but no, it persists. I installed some apps from the store to see if I needed apps for it to work, and still nothing. 

I do love the quest but I'm starting to have my doubts about how stable software is etc. 

Please could you guys at head office look into this to see if there's something going on either at your end, or if there's something I'm missing? 

I've also posted this in the support section as I don't know which category this fits best.
7iokfac1u78o.jpg
32 REPLIES 32

thowthoww
Level 2
I'm having the same issue here. But only the developer list! Everything else works fine.
It actually worked for 1 hour or so, but then stopped.
Facebook linked or not doesn't change anything.
I tried a different a account, meaning resetting the headset as well. Doesn't change anything.

juanyvos
Level 2
Same here.

jsdeprey
Level 2
I have had this issue since at least July, looked it this issue 8 months ago and never found this post. I opened a support ticket with Oculus on July 18th and they only told me to factory reset my Quest, I did it twice and still it still did not solve this issue, I replied to them about that and never got a response back. I gave up.
Everything worked except home to I just went to Library and Store etc. Strange thing is I also have a Oculus Go and it has the same exact issue and on same account. So I just tried unlinking my Facebook Account from my Oculus Account and I have my home screen back! it has been 8 Months with no home screen!
Oculus! get this fixed, how is it this bug exists at all that causes my Quest home screen to not load while signed in to Facebook account etc.?

AnotherAtreyu
Level 4
Bought a Quest for a Family Christmas Gift and I've been having the same issue since December 24th. Unfortunately, removing FB, factory reset, etc. don't do anything to solve it...

At first Oculus support seemed more than happy to help, and we went back and forth about a dozen times before I suddenly received a canned automated response about them being busy, and I haven't heard anything from them since...

I was planning on trying to drum up some interest regarding the issue on Reddit and the like, but deleted my posts as I know they are likely doing what they can to solve the issue and I don't want to turn people off the Quest, but the lack of communication is making it seem almost necessary? 

Knowing that some other users here have been made to wait more than half a year without a solution is disconcerting; so if you are reading this, Oculus, please get back in touch and tell me what you are doing to fix the issue. 
“If you are willing to look at another person’s behavior toward you as a reflection of the state of their relationship with themselves rather than a statement about your value as a person, then you will, over a period of time cease to react at all.” (~I really gotta remember this shiz~) ― Yogi Bhajan

Umpa_PC
Level 8
How many of you having problems have loaded side quest apps?
Oculus Rift S - Oculus Quest 128GB
MSI trident 3 7RB-200UK Intel Core i5-7400 3 Ghz x2
MSI GTX 1050 Ti (4GB) & MSI Aero GTX 1060 OC (6GB) & MSI Aero GTX 1070 OC 8GB
16 GB RAM x2, 1TB HDD x2, 1TB SSD x2
Windows 10 Home Edition Version 10.0.18363 Build 18363, Oculus version 17, Quest Version 17
Fan Cooling by Zotac FireStorm - AfterBurner cause me problems.

dc2889
Level 5
I fixed it after months of not having access to home,games,parties and friends tabs me contacting oculus directly with no help even though they tried. Great customer service as usual lol. In order to fix this issue you have to go into facebook or facebook the app. Then head over to your settings on facebook or the app. Enter the security tab then apps and websites. Click apps and websites then click apps websites and games tab. Then hit edit then select off now exit and go back. Wait ten seconds then security then apps and websites click apps and websites tab then click apps websites and games. Then hit edit then select on then you should get notifications from your oculus app saying your facebook friends have been added to your quest friends. after that your home,games,parties and friends tab should work.Your welcome 

sagepanda
Level 2
FIXED 
I had a similar issue: I could play games and surf the browser but the home screen wouldn't load properly. The store wouldnt load either (same something went wrong message). Games/aps wouldn't update nor download (updates were in the que but not downloading). Profiles wouldn't load, even after I disconnected facebook. and the OS was stuck searching for any new updates. The problem: my Disney Circle (wifi parental controls) had the Quest under son's account with 'Kid' filter applied. I moved the device to the Admin account (which does block adult content) and everything loaded/updated and no more error messages! 
If you are having issues, check any wifi restrictions/parental controls.

Zachary_Z
Level 2
I have the same problem, did anyone find a solution? Also I did the Facebook thing and it didn't work as well as making my Quest an Admin on my wifi.

senseiz
Level 3

Zachary_Z said:

I have the same problem, did anyone find a solution? Also I did the Facebook thing and it didn't work as well as making my Quest an Admin on my wifi.


Hey man. I've been watching the forums all day yesterday and today with the same deal.
Your wifi is not the issue. 

This is happening to lots of people since yesterday. My support ticket has no good info just canned responses. 

Here's a sampling of recent reports (I don't have enough rep to post actual links, forgive me)

- https:// forums.oculusvr.com/community/discussion/comment/758183#Comment_758183

- https:// forums.oculusvr.com/community/discussion/comment/758144/#Comment_758144

- https:// forums.oculusvr.com/community/discussion/92128/my-quest-home-store-library-etc-are-broken#latest

- https:// forums.oculusvr.com/community/discussion/comment/758103/#Comment_758103

- https:// www.reddit.com/r/OculusQuest/comments/i90za7/internet_issue/

- https:// www.reddit.com/r/OculusQuest/comments/i8sllh/i_need_help_please/

- https:// www.reddit.com/r/OculusQuest/comments/i8v3k8/quest_is_connected_to_wifi_but_wo_t_load_anything/

- https:// www.reddit.com/r/OculusQuest/comments/i8qsea/hey_all_just_received_my_first_quest_today

Zachary_Z
Level 2
Glad I'm not alone, but sucks to see others also struggling with this problem. Thanks for letting me know that others are also going through this. I guess I'll keep looking for more clues and hope to get it fixed.