Showing results for 
Search instead for 
Did you mean: 

Oculus Quest, connecting to bluetooth devices causes game lag?

Level 2
Hey everyone,

First time posting here, so if the question was already answered I couldn't find it, but my issues it like this:

Whenever I connect my bluetooth headphones (Glaxy Buds+ if that matters) or my speaker (JBL extreme 2) and enter BeatSaber it causes a ingame suttering/lag whtever u want to to call it where all the cubes instead of moving at regular framerate they move like 15 fps constantly, the rest of the game, I mean the sabers and the enviorment both run at the 72 fps (aka they are the regular smooths moing) but only the cubes move at 15 or 20 fps, If I disconnect the bluetooth device and just restart the lvl (not even the game) it works fine, if I reconnect and restart the lvl it goes again in the "laggy state", also idk if it matters but if I connect mid game and press continue the game bugs and nothing moves anymore (hence I mencioned the restart).

That;s all if anyone know's a fix please help me out.

Side note: I'm using the regular quest + regular beat saber, no oculus link or stuff like that, and for BT pairing I'm using the integrated experimental pair function, as for software I'm basically up to date, lates software version (in my about page it says version

Level 10
I tried this a while ago before the Bluetooth experimental feature was added but could enable BT from enabling developer mode and side loading. 

BeatSaber had stutter then, I recall other people posting the same issue. Other games didn’t stutter so much if I recall. I just use wired Kiwi design earbuds now so haven’t needed to try again. 

The BT feature is experimental so won’t be perfect and may cause undesirable effects. 

Level 2
same here it just stutters and it's really just choppy, any suggestions?

p:s im using airpods and regular quest, no links or mods or even anything. Just the Oculus Quest, airpods, and regular beat saber... bluetooth needs a fix in oculus quest NOW...

Volunteer Moderator
Volunteer Moderator
This is why BT headphones were initially not supported. Why not just plug in regular wired earbuds?

i7 5820K @ 4.25GHz | EVGA GTX 1080 SC | Gigabyte GA-X99-UD4 | Corsair DDR4 3000 32GB | Corsair HX 750W
SSDs: Intel 660p M.2 2TB, 3x Samsung Evo 1TB | Startech PCIe 4x USB 3.0 | Startech PCIe 2x USB C 3.1 gen2

Level 2
One way to solve is use a 3.5mm to bluetooth  transmitter 

Level 2

nalex66 said:

Why not just plug in regular wired earbuds?

Because I don't have any.

Level 2
Confirmed bug! Thanks for posting this - same problem here. Bluetooth connected my B&O Beoplay H9 to the Quest 2 and all of the music blocks were stuttering, so weird. Please fix!

Level 2
Same bug on quest 2

Level 2
No further news on this ? 
I just tried and got the same.

Level 2
same here, same problem