cancel
Showing results for 
Search instead for 
Did you mean: 

Oculus Quest not charging/charging slowly

peulza
Level 2
Hello.
I have an Oculus Quest since a year and a half now, and it always had worked well. 
I was playing as usual two days ago when I had to interrupt my playing session without turning the headset off, thinking it was gonna turn off by itself. Which it usually do. 
And it did, but since then, my oculus quest doesn't want to charge anymore. The led was not turning on while charging, until I moved the charger a little bit . The led was turned on, but the thing is , the headset was charging really slowly. (5% for 3 hours or something like that.)
I made a ticket on the support service , and I'm still waiting for an answer, so I'm asking this on the forum hoping someone will help.
I already tried to reboot the headset, turn it off via using the power and the lower volume button, and it just doesn't work. 
Also the adaptator is making some buzzing sounds while plugged in and plugged out, I don't know if it has a link but...it is what it is. 
Thank you for helping me out !
1 REPLY 1

PITTCANNA
Level 12
Try a different power brick, or replace the cable