cancel
Showing results for 
Search instead for 
Did you mean: 

Oculus Rift 2 PC link suddenly not recognized

jonah.falcon.7
Level 3

I'm playing Elite Dangerous with PC Link and suddenly I'm booted and the PC tells me "USB Not Recognized" and Device Manager says "Unknown USB Device (Device Descriptor Request Failed).

 

What the everliving hell?

3 REPLIES 3

jonah.falcon.7
Level 3

Oh. and it makes me feel warm and fuzzy when Windows is telling me the reason it can't recognize the device is that the device has malfunctioned.

jonah.falcon.7
Level 3

No one?

clouds5
Level 4

I have/had the same issue since ~January. When testing different USB ports on my PC it suddenly showed the same error message. Device not recognized. Now matter what I tried it wouldn't work. Opened a ticket but the techs couldn't help me either (I suggest you do the same, there are lots of people with this or other USB connection issues).

Here's something to try as a workaround: Put the Quest 2 into developer mode through the phone app. For me, as long as the headset is in dev mode it gets recognized by my PC, when i switch it off it's not recognized anymore. It's still broken, but at least I can use it.

I5-10600kf@5Ghz, 16GB DDR3600, RTX 2070