cancel
Showing results for 
Search instead for 
Did you mean: 

Oculus Service Failure

coolxwhip
Level 2

Everytime I try to open my apps, they load for a minute and then shut down. One app says “Oculus Service Failure, Please close app to try again”, other apps just shut down. Same thing happened to me yesterday and I ended up factory resetting my Oculus and logging back in and everything worked then. However when I try it today, it is back to not working. It is some issue with the Oculus not connecting to the server I think. Please help! I don’t want to have to factory reset my Oculus everytime I want to play a game 

3 REPLIES 3

OculusSupport
Community Manager
Community Manager

Hey there coolxwhip! We'd love to look into this with you to get your games working properly. We'd like you to make sure you're connected to a strong, reliable Wi-Fi connection. If possible you should try other Wi-Fi networks to see if performance improves. If it doesn't, please PM us or submit a support ticket HERE and we'll get to the bottom of this together. Thanks!

Hey! I have this same issue (scroll down it is in the same thread topic), and I tried this. It didn't work.

it isnt working for me either right now