Showing results for 
Search instead for 
Did you mean: 

Oculus can't see my WIFI at home

Level 2

So, I can connect my Quest 2 to my Mobile devices (tethered) which is also my work WIFI solution. There are no issues with this. When I bring my Quest 2 home, it cannot see my home WIFI network. Also I cannot see any of my neighbours WIFI signals. I have no issues with the home network on any other device, and on all other devices can see my neighbours WIFI signals.


When my home network is on the Quest 2 won't even see my tethered devices WIFI signals - even though they can be connected when it is off. 


I have added the 2.4 and 5GHz SSID's (different) to the Quest 2 manually. When I turn the Quest 2 on, it does connect and I can see all the SSID's from neighbours. After about 1 minute, they all disappear, and the Quest 2 is disconnected from the WIFI and is not able to be seen.


I have tried:

  • rebooting the router/modem
  • I have done on the Quest 2 a power cycle, and a factory reset
  • I have turned off the 2.4 GHz signal
  • I have turned off the 5GHz signal
  • I have turned off the Firewall on the modem/router
  • I have tried to connect to the network through the Oculus mobile app
  • There is no MAC, IP or website filtering
  • I have contacted Oculus Support
    • No success as yet with options suggested
  • I have contacted D-Link
    • No success as yet with options suggested

The modem/router is D-Link DSL-3890


Level 2

Is your network visible? Unlike many other devices Oculus does not connect if your SSID is not visible. I entered WiFi credentials but connected to the network only after making my SSID visible. Surprisingly, after making SSID invisible my device got disconnected. This is an unusual behaviour.