cancel
Showing results for 
Search instead for 
Did you mean: 

Oculus link extreme issue

Ok I can’t figure out what’s happening at ALL.

Oculus link just stopped working randomly for seemingly no reason.

 

Ive recently starting using cable link and air link and it’s worked to some extent but I just tried again and for some reason, it would always go back to my oculus quest Home Screen when I tried connecting. Oculus kept saying it couldn’t detect my quest but Steam VR kept coming up so my computer was obviously detecting the fact that I had it plugged in, help?

1 ACCEPTED SOLUTION

Accepted Solutions

texdade
Level 3

Fixed! Basically (if you are using a laptop like me) just disable the integrated GPU (via laptop software or windows): this should leave the discrete (nvidia) GPU on at all time and let the oculus link software work again

View solution in original post

8 REPLIES 8

hwangarang
Level 2

I started to have the same exact issue today.  Everything had been working fine since I last used it a couple of months ago.  My setup has not changed so I expected to be able to jump right on play my games as always.  Unfortunately, I experienced what you just described.

 

It's so awkward.  I get the same Enable Oculus Link message after connecting my cable.  I click it and it starts to process.  I see the three white dots.  After about 5 seconds, it jumps back to the home screen.  On the PC side, in the Oculus App, I see under the Notifications: "We can't find your headset. Please connect your headset."  But when I click on Device, I see my headset there with all green dots, ready to go.

texdade
Level 3

Very same problem here! Have you updated windows 10, the headset or the oculus link app by any chance?

I usually always perform any updates the system notifies me to update.

Oliver69sv
Level 4

radeon or geforce grafics ? radeon released new drivers this week solving an oculus issue

Ryzen7 2700X@3,8GHz, 32GB PC2666, Radeon RX5700XT 8GB, ROG STRIX 450E, Quest 2, Link cable & Air Link

I'm using the ROG Zephyrus G14 with the NVIDIA GeForce RTX 2060 Max-Q.  I applied the most recent update yesterday.

texdade
Level 3

Fixed! Basically (if you are using a laptop like me) just disable the integrated GPU (via laptop software or windows): this should leave the discrete (nvidia) GPU on at all time and let the oculus link software work again

View solution in original post

hwangarang
Level 2
Brilliant!  Just tried your solution and it worked!!  Thank you!!!
 
So that solved the problem, but I have to leave the integrated GPU disabled in order to use Oculus Link, which is a pain.  It didn't require this manual / workaround step before.  Something must have happened in an update somewhere.  Hopefully this will be fixed in a future update.
 
Out of curiosity, are you also having to leave your integrated GPU disabled?  I found a post that suggested this step and implied that once you disabled it then re-enable it, the system will then prioritize the dedicated GPU moving forward.  This didn't work for me though.  As soon as I re-enabled the integrated GPU, Oculus Link stopped working again.

Since I use my laptop as a semi-workstation, my iGPU is always disabled (since using only the dGPU gives better performance in high-fps games)