cancel
Showing results for 
Search instead for 
Did you mean: 

Oculus link suddenly not working after months of seamless PCVR gaming.

TeaFloor
Level 3

[EDIT] : After updating to the newly released game ready drivers (496.13) through GeForce Experience, and, as gary.clark.54584 suggested, repairing the oculus client by running the setup file again, oculus link seems to be working. I'm unsure which of the two actually fixed it, or if any actually did and the fix actually came from some update the oculus developers did, but what I'm sure of is that Oculus Link is currently working for me. Will update again if new issues arise.

 

[ORIGINAL POST] :

 

I'm seriously out of ideas.

I bought my Quest 2 in early July, and it's been working wonderfully since. I've been plugging it into my PC with that approved Anker USB 3.0 cable, and I've had absolutely no issues with it. Most games run perfectly, such as Blade & Sorcery, H3VR, Beat Saber, Boneworks, etc.


However, since today, oculus link just doesn't want to work at all anymore. Here's the exact chain of actions I take and the reactions from the Quest 2 :

  1. I plug the USB 3.0 cable in the Quest 2.
  2. I put the headset over my eyes and click "allow" or whatever the positive answer is at the prompt about sharing files with the computer. (I've seen tutorials saying that pressing "deny" is the preferrable option. I've however been pressing "allow" since forever with no issues, and pressing "deny" didn't do anything different either.)
  3. I get to the Oculus Home and open the quick settings menu (pressing the clock/battery/notification icon block at the far left of the task bar). I'd like to mention that prior to opening the settings, I get the usual notification over the task bar that oculus link is available in the settings.
  4. I click on the large "oculus link" block next to the Wi-Fi and Guardian ones of the same size.
  5. Screen turns black, the three dots loading loop appears to indicate that it's loading.
  6. The 3D Oculus logo appears in front of me.
  7. I see the infinite white grid-patterned link area, but only for a split second before the screen goes black again.
  8. After a short while, the 3D Oculus logo appears once more, again succeeded by a peek of the grid-pattern area, only to turn black again.
  9. Steps 7 and 8 are repeated in a loop endlessly, until I unplug the cable from my headset, thus breaking the Oculus Link connection and being sent back to the Oculus Home.

Usually, I go through steps 1 to 7 and once I'm in the white grid area, I can just select my monitor and mess around with SteamVR. The issue here is obviously that it doesn't last for more than a second before turning black again in a loop.

 

I feel like I tried every solution available, and yet absolutely nothing gave me the slightest inch of progress. Here's everything I've tried :

 

  • Rebooting computer
  • Rebooting Quest 2
  • Restoring Quest 2 to factory settings (complete reset by holding the power and volume-down buttons)
  • Reinstalling the Oculus App on my PC.
  • Updating my graphics card drivers to the latest ones through GeForce Experience.
  • Going back to a previous Graphics Card drivers version.
  • Rebooting router and modem.
  • Deleting the Quest 2 device entry on the Oculus desktop app, and adding it again.
  • Rebooting the Oculus software through the "beta" tab in the settings of the desktop app.
  • Trying Oculus Air Link instead of Oculus Link. This resulted in exactly the same results as with Oculus Link.
  • Verifying the cable connection through the Oculus desktop app in the devices tab. Results showed no issues.

I changed absolutely nothing in my computer that could've caused such an issue. The cable is in perfect condition, my headset is charged, no major updates of any software on my computer that could be even remotely related to Oculus Link has been made. I just don't know what to do at this point. I absolutely loved my previous VR sessions with my Quest 2 and would love to use it again, but this sudden Oculus Link issue makes my Steam games impossible to enjoy.

Here's my specs, in case anyone wants them :

 

Windows 10 x64

Intel Core i7-9700

NVIDIA GeForce GTX 1660 Ti (latest game ready drivers are 472.12)

16 GB RAM

 

If absolutely anyone encountered a similar issue and solved it, I would be most grateful if you would share the solution that worked for you.


Have a great day!

 

34 REPLIES 34

RadMadDad
Level 3

I have the exact same problems as you (it started not working today, 10/9), except I never get past the initial black screen and dots (the white grid never appears). I also tried submitting a ticket, but didn't get any confirmation after I hit submit, so I don't even know if it went through. This sucks and the (lack of) tech support is doubly frustrating.

ItsFelix
Level 3

I've had an almost identical problem and its so frustrating because it started messing up out of nowhere for seemingly no reason. I've tried everything I could think of and most of what you tried to fix it to no avail.

Are you on a laptop? I'm on a laptop. Oddly enough, I was able to connect it to a desktop PC without issue. I wonder if it has something to do with the NVIDIA cards for laptops.

I am on a laptop actually, so maybe that is the issue. I don't have a desktop to see if it works there, sadly.

OculusSupport
Oculus Community Manager
Oculus Community Manager

Hey there, we would love to offer you with the best assistance.


We have noticed there are a lot of really helpful tips here. We would like to ask if you are able to provide us with the following: 

  • A photo of the Anker cable you are using.
  • Does your device function properly as a stand alone?
  • Are you using Windows 10 latest update?
  • Do you happen to see any error messages?

Please be sure to reach back out with these details here, so we can resolve this matter together.

I have the same issue a black screen and sometimes a flickering screen. Issues began immediately following an nvidia driver update. 

  • I am using the official oculus cable.
  • It works stand-alone.
  • I am using fully updated Windows 10.
  • I have no error messages.

I have the same issue but on a desktop. It occurred right after updating Nvidia drivers. Any chance your desktop and laptop are running different driver versions?

So, what (just) worked for me is reverting to my old AMD Ryzen drivers (per Oculus TS, the newest version doesn't support Oculus which seems... weird, but ok). If your laptop also has an AMD processor, I'd try that.

Don't know if this will help you, but what (just) worked for me is reverting to my old AMD Ryzen drivers (per Oculus TS, the newest version doesn't support Oculus which seems... weird, but ok). If you also use an AMD processor, I'd try that.

Yeah, actually my desktop has an Intel processor, so if the problem is AMD drivers, then that would explain why I didn't experience the problem on my desktop.