cancel
Showing results for 
Search instead for 
Did you mean: 

Oculus link suddenly not working after months of seamless PCVR gaming.

TeaFloor
Level 3

[EDIT] : After updating to the newly released game ready drivers (496.13) through GeForce Experience, and, as gary.clark.54584 suggested, repairing the oculus client by running the setup file again, oculus link seems to be working. I'm unsure which of the two actually fixed it, or if any actually did and the fix actually came from some update the oculus developers did, but what I'm sure of is that Oculus Link is currently working for me. Will update again if new issues arise.

 

[ORIGINAL POST] :

 

I'm seriously out of ideas.

I bought my Quest 2 in early July, and it's been working wonderfully since. I've been plugging it into my PC with that approved Anker USB 3.0 cable, and I've had absolutely no issues with it. Most games run perfectly, such as Blade & Sorcery, H3VR, Beat Saber, Boneworks, etc.


However, since today, oculus link just doesn't want to work at all anymore. Here's the exact chain of actions I take and the reactions from the Quest 2 :

  1. I plug the USB 3.0 cable in the Quest 2.
  2. I put the headset over my eyes and click "allow" or whatever the positive answer is at the prompt about sharing files with the computer. (I've seen tutorials saying that pressing "deny" is the preferrable option. I've however been pressing "allow" since forever with no issues, and pressing "deny" didn't do anything different either.)
  3. I get to the Oculus Home and open the quick settings menu (pressing the clock/battery/notification icon block at the far left of the task bar). I'd like to mention that prior to opening the settings, I get the usual notification over the task bar that oculus link is available in the settings.
  4. I click on the large "oculus link" block next to the Wi-Fi and Guardian ones of the same size.
  5. Screen turns black, the three dots loading loop appears to indicate that it's loading.
  6. The 3D Oculus logo appears in front of me.
  7. I see the infinite white grid-patterned link area, but only for a split second before the screen goes black again.
  8. After a short while, the 3D Oculus logo appears once more, again succeeded by a peek of the grid-pattern area, only to turn black again.
  9. Steps 7 and 8 are repeated in a loop endlessly, until I unplug the cable from my headset, thus breaking the Oculus Link connection and being sent back to the Oculus Home.

Usually, I go through steps 1 to 7 and once I'm in the white grid area, I can just select my monitor and mess around with SteamVR. The issue here is obviously that it doesn't last for more than a second before turning black again in a loop.

 

I feel like I tried every solution available, and yet absolutely nothing gave me the slightest inch of progress. Here's everything I've tried :

 

  • Rebooting computer
  • Rebooting Quest 2
  • Restoring Quest 2 to factory settings (complete reset by holding the power and volume-down buttons)
  • Reinstalling the Oculus App on my PC.
  • Updating my graphics card drivers to the latest ones through GeForce Experience.
  • Going back to a previous Graphics Card drivers version.
  • Rebooting router and modem.
  • Deleting the Quest 2 device entry on the Oculus desktop app, and adding it again.
  • Rebooting the Oculus software through the "beta" tab in the settings of the desktop app.
  • Trying Oculus Air Link instead of Oculus Link. This resulted in exactly the same results as with Oculus Link.
  • Verifying the cable connection through the Oculus desktop app in the devices tab. Results showed no issues.

I changed absolutely nothing in my computer that could've caused such an issue. The cable is in perfect condition, my headset is charged, no major updates of any software on my computer that could be even remotely related to Oculus Link has been made. I just don't know what to do at this point. I absolutely loved my previous VR sessions with my Quest 2 and would love to use it again, but this sudden Oculus Link issue makes my Steam games impossible to enjoy.

Here's my specs, in case anyone wants them :

 

Windows 10 x64

Intel Core i7-9700

NVIDIA GeForce GTX 1660 Ti (latest game ready drivers are 472.12)

16 GB RAM

 

If absolutely anyone encountered a similar issue and solved it, I would be most grateful if you would share the solution that worked for you.


Have a great day!

 

32 REPLIES 32

No Ryzen, but I'll try reverting back to older nvidia drivers. Thanks for the followup!

sk8er431
Level 2

same here, it stopped working after uodating my nvidia driver. will try reverting to old driver tomorrow and see how it goes.

I tried every driver available back to June, but no success. I hope you have better luck. If so, let me know which driver version.

YanaArtis
Level 4

I had the same issue on the laptop I've purchased couple days ago (ASUS ROG G513, Ryzen-7, RTX 3060). Everything worked fine (except one issue(*) in the Oculus Home) until I installed Nvidia GeForce Experience and updated Nvidia driver. That completely broke Oculus Link - I saw the black screen instead of Oculus Home. I have tried all tips & tricks I googled but nothing helps. But I've found the cure. I installed Nvidia Studio driver 462.59 - and Oculus Link is working now!

 

(*) But there still remains the issue I mentioned above. The projection of PC screen in the oculus home is totally black with mouse pointer over it. Cannot find how to fix that. 

I know how to "fix" your remaining issue (but as explained below I wasn't satisfied with the result). The issue is that your computer is trying to render the desktop with your (better) GPU, rather than your integrated graphics card. To fix this, in the Windows toolbar, type "Graphics Settings" (or open Settings then go to Display, then Graphics Settings). Under "Graphics performance preference," select "Browse" and select "C:\Program Files\Oculus\Support\oculus-runtime\OVRServer_x64.exe" (that's the default path; if you installed the Oculus software somewhere else, go there; or just search for "OVRServer_X64.exe"). Click "Add." Then select "Options" and set it to "Power saving." Click save and reboot both the computer and your headset (I'm definitely sure you need to reboot your laptop, and just did the headset in an abundance of caution). Credit and source is here: https://www.reddit.com/r/oculus/comments/mvk5e1/comment/gw7br01/?utm_source=share&utm_medium=web2x&c... (but please note that it omits the reboot step, which I found to be necessary)

 

My problem with the solution was that, running off the integrated graphics, everything was so laggy that it wasn't worth the effort and I reverted back to the "Performance" option (rather than "Power Saving"). Hopefully your experience is better.

Try the newest graphics driver, but revert your processor (Intel or AMD) to the last driver version. That's what worked for me. I think what happened was my computer updated my AMD processor at around the same time I updated my NVIDIA drivers. Reverting to the prior version of my AMD driver fixed the problem. I also turned off "auto-updates" (which makes me a bit nervous).

Thank you 🙂 I have tried the same fix recipe with the same results... I have tried switch the performance for the following applications:
1) C:\Program Files\Oculus\Support\oculus-runtime\OVRRedir.exe
2) C:\Program Files\Oculus\Support\oculus-runtime\OVRServiceLauncher.exe
3) C:\Program Files\Oculus\Support\oculus-runtime\OVRServer_x64.exe
4) C:\Program Files\Oculus\Support\oculus-client\OculusClient.exe
5) C:\Program Files\Oculus\Support\oculus-dash\dash\bin\OculusDash.exe
I have tried all 32 possible combinations 🙂 And discover that only OVRServer_x64.exe affects on "black PC screen issue". If I set it to high performance (RTX 3060) everything is fine and fast but PC screen projection is black. If I set OVRServer_x64.exe to energy-safe mode (AMD graphics card), every thing is too laggy, but PC screen content is shown in VR.

Probably I'll try to resolve this issue next weekend.

Thanks for your information, I'm facing exact the same problem and my laptop is also ASUS ROG (Ryzen and RTX 3070). I tried everything, reinstall Oculus, use different linking cable, reboot machine on my Quest 1, and even I bought a new Oculus Quest 2 to confirm it is software issue instead of my Quest 1 is broken. Until I saw this post and roll back to 462.59 it is starting to work.

 

Nice job NVIDIA, I guess they force me to upgrade my Quest to Quest 2.

Repair doesn't fixed the issue on my laptop ASUS ROG Strix G513IM. I have Nvidia Studio driver 472.12. Oculus Link still doesn't work.

Have you tried updating the drivers through GeForce Experience? 472.12 didn't work for me, but the latest 496.13 released earlier this week seem to have fixed it, or perhaps it was an update on the Oculus Devs side and there's some updates you need to make with your headset. The latter seems probable, as there appears to be a whole new interface to the oculus link menu : An editable virtual space, similar to SteamVR.

 

Regardless, I suggest updating to the 496.13 Nvidia drivers.