cancel
Showing results for 
Search instead for 
Did you mean: 

Oculus link suddenly not working after months of seamless PCVR gaming.

TeaFloor
Level 3

[EDIT] : After updating to the newly released game ready drivers (496.13) through GeForce Experience, and, as gary.clark.54584 suggested, repairing the oculus client by running the setup file again, oculus link seems to be working. I'm unsure which of the two actually fixed it, or if any actually did and the fix actually came from some update the oculus developers did, but what I'm sure of is that Oculus Link is currently working for me. Will update again if new issues arise.

 

[ORIGINAL POST] :

 

I'm seriously out of ideas.

I bought my Quest 2 in early July, and it's been working wonderfully since. I've been plugging it into my PC with that approved Anker USB 3.0 cable, and I've had absolutely no issues with it. Most games run perfectly, such as Blade & Sorcery, H3VR, Beat Saber, Boneworks, etc.


However, since today, oculus link just doesn't want to work at all anymore. Here's the exact chain of actions I take and the reactions from the Quest 2 :

  1. I plug the USB 3.0 cable in the Quest 2.
  2. I put the headset over my eyes and click "allow" or whatever the positive answer is at the prompt about sharing files with the computer. (I've seen tutorials saying that pressing "deny" is the preferrable option. I've however been pressing "allow" since forever with no issues, and pressing "deny" didn't do anything different either.)
  3. I get to the Oculus Home and open the quick settings menu (pressing the clock/battery/notification icon block at the far left of the task bar). I'd like to mention that prior to opening the settings, I get the usual notification over the task bar that oculus link is available in the settings.
  4. I click on the large "oculus link" block next to the Wi-Fi and Guardian ones of the same size.
  5. Screen turns black, the three dots loading loop appears to indicate that it's loading.
  6. The 3D Oculus logo appears in front of me.
  7. I see the infinite white grid-patterned link area, but only for a split second before the screen goes black again.
  8. After a short while, the 3D Oculus logo appears once more, again succeeded by a peek of the grid-pattern area, only to turn black again.
  9. Steps 7 and 8 are repeated in a loop endlessly, until I unplug the cable from my headset, thus breaking the Oculus Link connection and being sent back to the Oculus Home.

Usually, I go through steps 1 to 7 and once I'm in the white grid area, I can just select my monitor and mess around with SteamVR. The issue here is obviously that it doesn't last for more than a second before turning black again in a loop.

 

I feel like I tried every solution available, and yet absolutely nothing gave me the slightest inch of progress. Here's everything I've tried :

 

  • Rebooting computer
  • Rebooting Quest 2
  • Restoring Quest 2 to factory settings (complete reset by holding the power and volume-down buttons)
  • Reinstalling the Oculus App on my PC.
  • Updating my graphics card drivers to the latest ones through GeForce Experience.
  • Going back to a previous Graphics Card drivers version.
  • Rebooting router and modem.
  • Deleting the Quest 2 device entry on the Oculus desktop app, and adding it again.
  • Rebooting the Oculus software through the "beta" tab in the settings of the desktop app.
  • Trying Oculus Air Link instead of Oculus Link. This resulted in exactly the same results as with Oculus Link.
  • Verifying the cable connection through the Oculus desktop app in the devices tab. Results showed no issues.

I changed absolutely nothing in my computer that could've caused such an issue. The cable is in perfect condition, my headset is charged, no major updates of any software on my computer that could be even remotely related to Oculus Link has been made. I just don't know what to do at this point. I absolutely loved my previous VR sessions with my Quest 2 and would love to use it again, but this sudden Oculus Link issue makes my Steam games impossible to enjoy.

Here's my specs, in case anyone wants them :

 

Windows 10 x64

Intel Core i7-9700

NVIDIA GeForce GTX 1660 Ti (latest game ready drivers are 472.12)

16 GB RAM

 

If absolutely anyone encountered a similar issue and solved it, I would be most grateful if you would share the solution that worked for you.


Have a great day!

 

34 REPLIES 34

I have tried 496.13 last week but it doesn't fixed the issue. Tried it again right now but with no success 😞 So, I am back on 462.59...

New update doesn't work for me either. I'm working with Oculus support, but nothing has worked so far.

ItsFelix
Level 3

I tried everything I've seen suggested here and by a certified technician I have been talking to and absolutely nothing is working, its so frustrating

OculusSupport
Oculus Community Manager
Oculus Community Manager

Hello, Felix!

 

We see that you are having an issue with Oculus Link not working correctly when trying to tether your Oculus device to your PC. We appreciate the work you have done so far to try and resolve this issue. Are you receiving a specific error message, or is the Oculus device not being recognized by the PC?

 

You may also want to try:

  • Disabling any Antivirus programs that could prevent the sharing of information between your Oculus device and PC.
  • Inspecting your Oculus Link cable for any damage, and try updating your USB drivers as well.
  • Ensuring that both your Oculus device headset and Oculus app are fully updated.

If you are still experiencing an issue with linking your Oculus device to your PC, please send us a Private Message or submit a support ticket here for further assistance. We'll do our best to get you back into the PC VR gaming experience! 

The issue with broken Oculus Link after installing new Nvidia drivers happened more than month ago. Guys from Oculus, have you found the cure? Oculus Support asked me once more to check Game Mode, USB ports settings, try different USB ports and different USB cables - the same useless advices as month ago.

 

Is there any hope that Oculus will resolve this issue? To work with Quest and Nvidia Omniverse I need to reinstall Nvidia drivers every time! Oculus was the perfect platform. But it seems, worth to choose another VR headset 😞