cancel
Showing results for 
Search instead for 
Did you mean: 

Opening apps on my Quest 2 through virtual desktop defaults to SteamVR. I get stuck in lobby...Help!

Fl1ntst0n3
Level 3

Hi all, I recently bought a Quest 2 and I'm very excited to start using Adobe Medium for sculpting. It's the main reason I bought it as I sculpt in 3D for a living, usually in ZBrush. But when I open Virtual Desktop and connect to my gaming pc, I try to open an app...any app...and it takes me to SteamVR by default, where I only have a couple games and can't access the other games/apps on my pc.

 

I have Virtual Desktop on my Oculus, and Virtual Desktop Streamer and Revive are both downloaded on my PC. That all seems to be working, but even selecting apps straight from Revive does not seem to work. It often selects an adjacent app or game to the one I want (Medium!!) and either way directs me to the SteamVR lobby/room when I leave the incorrect app. I sometimes also get an error or "fatal" error from Medium (when I manage to select it properly) saying that I don't have a Rift.

 

Has anyone else experienced this and does anyone have a solution?

 

Otherwise loving VR though, dying to keep trying more experiences.

Thanks so much! 

4 REPLIES 4

PITTCANNA
Level 11

Try this:

Get VD running on PC and Quest in desktop view mode. Open up the hidden items in your task bar (the ^ ) in the lower right and 'right click' (B) the green VD streamer icon. Chose 'Inject Game'. Navigate to the exe.

If it doesn't work, then you may have to launch oculus home before starting VD. For a game that needs SteamVR (like modded Skyrim via SKSE), I first bring up the VD HMD menu and chose LAUNCH STEAM VR, then go back to desktop mode and inject.

 

or go to games tab and launch the program or launch the steam vr lobby.

nalex66
Volunteer Moderator
Volunteer Moderator

Are you using the Games menu in Virtual Desktop, or trying to open games directly from your PC desktop? Since VD was updated to work natively with Oculus PC apps, you don't need ReVive, but you do need to use the VD Games menu (left controller menu button to open VD menu, then choose Games to see all your Oculus and SteamVR apps, and launch them from there).

i7 5820K @ 4.25GHz | EVGA GTX 1080 SC | Gigabyte GA-X99-UD4 | Corsair DDR4 3000 32GB | Corsair HX 750W
SSDs: Intel 660p M.2 2TB, 3x Samsung Evo 1TB | Startech PCIe 4x USB 3.0 | Startech PCIe 2x USB C 3.1 gen2

Selecting from the games menu usually gives me the same result as selecting a game/app from Revive or the desktop directly. They will either open or error out for some other reason, then if I choose to exit the app or "view in VR" (in the case that I opened it on my desktop), it takes me straight to the Home in Steam VR and I can't leave without exiting VD entirely. I know the malfunctioning apps are another issue, but I don't think I can start resolving them until I sort out this auto-open issue in SteamVR.

I'm not sure what you mean by "launch oculus home before starting VD"? The quest defaults to oculus home when I start the headset, then I choose VD from my app list. The issue isn't really getting into a steamVR game, those come up in the SVR lobby. I need to access an app I have on Oculus on my PC without opening SteamVR, but right now it auto-opens and takes me to the SVR Home, and I have to exit VD to leave. It becomes a bit of a vicious cycle 😅

Also, I tried "injecting" an .exe through the VD streamer icon, but Medium doesn't appear on the list. It looks like I have to open it directly from the Oculus App.