cancel
Showing results for 
Search instead for 
Did you mean: 

Puzzled about Quest2 stuttering/warping/malfunction Link Issues on a z490 /i9-10900K computer

NSXTAS
Level 2

I have an issue that I cant get to the root of, and like to share my findings here, to see if i can get any help. I got a Quest 2 headset earlier this year, and connected it to an older PC with an AMD 2990WX on an Asus Zenith Extreme MB and a RTX2080 graphics card.

Blown away by the Oculus Link / Air Link experience in Microsoft flight simulator 2020 that i have been tinkering with, I realized the old Threadripper was maxing out, and I decided to install the Quest 2 and MS flight sim on my newer computer, a Asus Z490F Gaming with a i9-10900k (running stock speeds, I'm too old for overclocking tinkering) and a RTX 3090 card.

To my big surprise, the experience brought me back to the -00's. The image you get in the Quest is warped and edges are "floating" on the curved dash panel, and if you move head around there is warping stuttering and general buginess. (both on a cable that is measured to > 3.0GB in the oclulus app, and wireless link. No difference in experience). If I connect to PC, the desktop is displayed statically shown ok within Quest if i hold my head still, but when i load MS Flight Sim, and the program has loaded, the picture in the Quest 2 is mega warping and I can never start to fly, since the picture is lost after a few sec, and never reconnects. The picture on the regular display is fine, it is just the Oculus Link that seems to be the issue. I have tried to swap graphics cards between the 2 rigs, and reinstalled a fresh win 10 and 11 on the PC that shows issues, without any positive results. I have searched high and low on most corners of internet, and still have no clue whats going on. does anyone on this forum have any idea what could be causing it? i'm currently stress-testing all individual components on the Z490 PC to see if I can find any issues. also worth mentioning, the Z490 runs MS flight Sim flawlessly on a regular 4K display, it is just the Oculus Link that seems to be the issue.

 

3 REPLIES 3

TomCgcmfc
Level 15

@NSXTAS  Seems there have been a number of usb issues with Asus z490 motherboards.  I suggest you Google ' Asus z490 motherboard issues ' and see if you can find a fix.  I had a quick look and there seemed to be fixes like updating the bios and updating usb drivers before actually plugging in a usb device. 

 

It also seems like the usb3.1 gen2 type c port is pretty picky on what cable it works best with.  Apparently the cable needs to be usb3.1 gen2 rated (10Gbps) which even the official Link cable does not have (5Gbps).  The only link cable that I'm aware of that is true usb3.1 gen2 (10Gbps) is the new VR Cover 5m Premium Link Cable.  I actually have this and it works great.  It is also Optical and actually better than my official one imho.

 

Anyway, good luck sorting this all out mate.  Cheers.

9 9900k, rtx3090, 32 Gb ram, 1tb ssd, 4tb hdd. xi hero wifi mb, 750w psu, Q2 w/Air Link, Vive Pro

NSXTAS
Level 2

hi Tom and thank you for your feedback.

i will dig deeper into the USB issues, but with Oculus USB test giving me a >3GB/s to the headset over cable, and having the same issue over wireless link, I am more gained to it is the actual Oculus PC Software, rather than the actual link carrier to the headset.

The hunt continues.

Thanks

 

@NSXTAS Are you able to use other Oculus games with either Link or Air Link?  Could just be a setting thing like too much bitrate.  Use ODT to set everything at defaults and/or Zero's to begin with.  I enable link sharpening and disable ASW.  You need to restart Oculus Services Runtime for these to take effect.  Easy way is just to exit and restart your Oculus desktop app.  With Air Link I use the rift home dashboard setting at 200mbps dynamic.

 

Also, if you have opted into the beta v34ptc, opt out and go back to stable v33.  You may also want to run an Oculus desktop Repair.  I needed to do this a few days ago and it improved things for me.

 

I also have a pretty strong desktop gaming pc (see my signature; i9 9900k/rtx3090, 32Gb ram, asus z390) and I also have a good/recommended Router/WIFI setup.  Both Link and Air Link work great for me.  The sweet spot for me with Oculus Desktop app device graphics setting is 80Hz and res slider full right (Equiv to Q2 native screen res).

 

Anyway, good luck and cheers mate.

9 9900k, rtx3090, 32 Gb ram, 1tb ssd, 4tb hdd. xi hero wifi mb, 750w psu, Q2 w/Air Link, Vive Pro