cancel
Showing results for 
Search instead for 
Did you mean: 

Quest 2 Headset not detected (TRIED EVERYTHING)

tehjaywen
Level 2

hello. i am new to the VR community and i know this topic is common but i cant seem to find a solution for my problem 😧

 

I bought the quest 2 for 1 purpose - Sim racing. Im trying to play it with Oculus Link but for some reason my pc does not detect my vr headset at all despite plugging it into the USB 3.0 / 3.1 port. Ive tried every solutions i can find on the net but none of them works. Ive tried updating my usb ports drivers via device manager (i didnt actually as it says im using the latest version already), reinstalling drivers via device manager, updating my bios to latest version, changing usb ports, reinstalling oculus software, enabling dev and usb debugging, updating both software and vr to the same version (v25/v26). I dont know what else to do.

 

I am using an aftermarket C to A cable that costed me around $60

 

However using a REGULAR USB type C phone cable does work but it detects it as USB2.0, not 3.0

 

Here are my specs:

Zotac RTX 2060

Z390 Aorus Elite

16GB RAM

i5 9400F

8 REPLIES 8

PITTCANNA
Level 12

is your computer a laptop or desktop?

Do you have usb 3.0 ports?

Are the other devices drawing too much power?

 

desktop. i have like 5 usb 3 ports and 3 usb 3.1 ports. 

im not too sure. ive only got 2 mouses, keyboard, headphones and g29 (switched off) connected

Viscerous
Level 4

Since the 'regular' cable works, I think it might be the cable. A fair few cables sold seem to be only for charging your devices and don't carry real data or are otherwise limited to USB 2.0.

So try removing some items, and putting them in low bandwidth ports.

 

and if you havent done so test the bandwith of the 3.1 vs. 3.0, if the cable is only 3.0 and its 3.1 slot then it probally wont work to well.

 

So connect to a blue 3.0 slot and run the test.  if you get green dot, then use that port.

 

Also depending on length of the cable you might stretching a bit with the bandwidth.

Make sure the oculus app software and headset are within 1 version of eachother.  If your the beta access channel in the oculus app, just exit out of that.

i would remove the additional mouse,  headphones and just use the oculus virtual driver for sound when your sim racing.

also make sure any power settings are not set too low.  so if your using any power saving features and turn them off, then close out of any capture software that overides your gpu.

i am using USBDeview to do the "test". Despite having mostly blue usb 3.0 ports, the software only shows usb 1.10 and 2.0 under the "USB Version"

Is this not the literal definition of false advertising? i bought a oculus brand li k cord thats only ever registered as type to despite my laptop having only type 3 slots. why would oculus open themselves to such a lawsuit?

Taiyaki1998
Level 2

i dont know,my oculus link stopped working overnight,ive tried everything ive found online other then building a new pc from the ground up,i genuinely feel hurt,ive not had vr long,and used it to get exercise,even bought a new laptop,top of the line and it realy hardly worked then....now nothing,ive been fighting with it for hours and have uninstalled reinstalled,and restarted countless times and im kinda close to crying.if anyone finds a fix please let me know