Showing results for 
Search instead for 
Did you mean: 

Quest 2 PCVR stutter (Alyx/Boneworks) (Link cable, AirLink, VirtualDesktop)

Level 3

The problem:


Roughly every 1-2 seconds, there's a small judder/stutter in PCVR games when moving. It's almost like a previous frame is rendered again. It is very noticable in alyx and boneworks using the joystick to move left/right and looking at a static object. I assume people playing with other movement types wont notice it easily.

It does not show:

  • On steamvr frame graph
  • On any of the oculus debug tool performance overlays, performance is rock solid on all graphs.
  • On the desktop window fro boneworks/alyx
  • On the steamvr vr view

Only shows in headset.


It occurs:

  • In alyx using steamvr
  • In boneworks using steamvr
  • In boneworks from the oculus store

I have tried two PC's:


  • Intel i7 8700K
  • 16 GB 3000mhz CL14 RAM
  • Nvidia GTX 1080


  • AMD Ryzen 5800x
  • 32 GB 3600mhz CL16 RAM
  • Nvidia RTX 3070

Most testing has been done on PC#2, but the experience is exactly the same.


What I have tried:

  • Official link cable, airlink and virtual desktop
  • Factory reset headset
  • Fresh windows install with only oculus client and steamvr installed, nothing else at all
  • Disable game mode
  • Turn off super sampling in steamvr (pretty much all combinations of steamvr/oculus settings)
  • Turn off ASW in oculus debug tool
  • Turn down all settings in game and run at lowest resolution in both oculus and steamvr. This in turn ran alyx with a frametime of about 1 ms.
  • Raised priority of all combinations of involed processes (oculus server, vrserver, the game etc.)
  • Used all combinations of the common alyx launch options.
  • Disable game mode in windows
  • Set the CPU/GPU profile to level 4 via. sidequest.
  • 72hz, 80hz, 90hz, 120hz (vd)
  • More stuff I forgot probably


  • I get 2.5 gbps on the USB test
  • There is no delay using airlink or vd. VD shows no network latency spikes. I run 2.5 gbps LAN to a wifi 6 router.
  • Nvidia drivers are the newest.

I have read countless of topics complaining about steamvr/alyx/boneworks stuttering.


My first thought is:


It might be the nvidia driver thing:


However it seems like it should be solved unless you run GPU monitoring software, which a fresh windows install obvously doesn't have. Odds are that this might not be the case, but everyone with new nvidia drivers should experience it, and some people claim to have a completely smooth pcvr alyx/boneworks experience? Are they just not using smooth locomotion and not noticing it?


My second thought is:


My headset is either broken or the stutter is a software error, either with the oculus compositor/encoder or the decoder on the headset. Again here, other people should experience it.


Third thought:


It's just a general thing with quest 2 and people just don't notice it? I experience no issues at all with native headset games.


I have only had the quest 2 for a couple of months and while I've enjoyed native games (mostly beatsaber), it has been a huge dissappointment having so many issues with PCVR.


Anyone have any advice at all? I'm about at that point where I consider returning it as defective.


If you want to test it, just boot up alyx or boneworks, look at a static object fairly close to you and move left to right to left continuously (smooth locomotion). You should see a small stutter every once in a while.


Level 2

New Quest user running a 5600x, 3070ti 16gb ddr4 3600mhz


Exactly the same issue as @ghodzy  has i think.  Basically whether running Virtual Desktop, airlink or cable I encounter a frame drop and micro stutter whilst moving.  Looking around Im fine.  

If i set to 90hz it drops by 2 or 3 frames causing a stutter (minute but noticeable and immersion breaking)
If i set it to 80hz still a drop by 2 or 3

Same at 70hz and at 60hz


PC has plenty of headroom and is smooth on when looking at PC monitor.   Running a 600mbps broadband connection running via ethernet to PC and a 5ghz connection to quest 2 with a connection speed of 866mbps


Tried everything and still no joy.  I'm assuming its a lost cause considering the number of posts here and across the internet

Level 2

I too have this exact issue, and I'm at least a little relieved to see I'm not the only one. There is absolutely some sort of tracking bug when it comes to movement of the controllers in SteamVR games. Once you notice it, it becomes very distracting very quickly.


For reference, my specs:



-32gb RAM

This worked for me. Tested Skyrim VR only. The stutter is gone, but the image is less sharp.

THANK YOU. I've been trying to figure out what was going on and nothing was working but disabling link sharpening in the debug tool worked like a charm.

Level 2

i am also on this endless quest to fix this issue.

Swaped my entire hardware, GPU, CPU, RAM, storage in the hope that would fix this.

I agree with your last point, i think most people don't notice, as a lot of people sensibilities to this kind of stuff is different, it and claims its run fine in their system.