cancel
Showing results for 
Search instead for 
Did you mean: 

Quest 2 USB not recognizing: This device cannot start. (Code 10)

Anonymous
Not applicable
So my Quest 2 was working just fine until two days ago.  I plugged it in and nothing was happening.  I checked the device manager and it kept popping up as a USB composite device with "This device cannot start. (Code 10)".  I tried everything, I've uninstalled every USB device.  Restarted my computer several times.  Used multiple cables and ports.  I've even reinstalled windows itself and the code persists.  When I plug my Quest 2 into my laptop it still runs just fine but it absoluetly refuses to work on my desktop now.  Any ideas?
7 REPLIES 7

ColeTrickle28
Level 2
It happens exactly the same. Have you been able to solve it?

TheCrowing
Level 3
Is there any solution to this? I have the same problem with the Quest 2, I installed the ADB drivers from the website and it doesn't seem to work it still shows up in Device Manager as USB Composite Device and shows "This device cannot start. (Code 10)".  Setting up on a different computer works with the same cable.  I tried different USB ports.

This only seems to happen when I have Developer Mode enabled, which I'm trying to use to sideload projects.  Disabling Developer Mode it is recognized and works with Oculus Link with no issues.

TheCrowing
Level 3
I was able to get this working, however I don't know exactly which of the following things caused it work so I'll share for anyone else that is having the same problem.

1. Unplugged all other USB devices except for Mouse and Keyboard
2. Followed the steps here for installing the ADB driver (Apparently I'm not allowed to post links) Search on Reddit Installing Oculus Go/Quest ADB Drivers on Windows 7 Issue and Solution
3. Delete adbkey & adbkey.pub from C:\Users\[USERNAME]\.android
4. Reboot and see if it now is recognized

Hopefully this works for someone else.

adalisanphd
Level 2

I had the same problem. Step 3 solved it for me.

My case was complicated as I migrated my Windows 10 PC to a new system. I uninstalled and reinstalled Oculus Win PC Software, removed everything USB. Nothing worked until I deleted the adb keys.

Never in a million years I would have thought the keys used in  adb connection had something to do with windows 10 not recognizing the device. I thought it was a USB power issue.

I wish Oculus software and specifically adb was better at error messages.

 

Hey,

I have tried every single solution on the internet and I am yet to find a solution. I've tried literally everything. Literally.

Anyone got any ideas?
(Running windows 11)

Hey there, TrionR! We're sorry to hear you're having this issue and none of the previous suggestions have worked for you. We appreciate you stating that you're running Windows 11, as this helps us identify the most likely cause of your issue.

 

At this time, Windows 11 is not yet supported with our software. Our teams are working hard to change this so our users no longer have this obstacle in the way of their PCVR gaming. In the meantime, we recommend checking out this public support article for more information on what PC specs we suggest using for optimal PCVR performance.

NewriderCalif
Level 2

Go to you're manufacture of the motherboard and download the usb hub drivers. And see

from there if it works. Also if you don't have update go device management on pc for that hub

and find out device id.