cancel
Showing results for 
Search instead for 
Did you mean: 

Quest 2 keeps losing 5GHz wifi! Keeps disconnecting

cbcharlee
Level 2
After a while of use, my Quest 2 will all of a sudden say it's not connected anymore, and when I go to wifi, all the 5GHz networks are now missing!  I then only see the 2.4GHz networks.  A reboot fixes this but it's happened over 3 times now.  Is this a known issue?  Is there any fix or anything I can try? I want to use 5GHz wifi!

130 REPLIES 130

revanmj
Level 2
I have similar issue.

I have separate 2,4 GHz and 5 GHz SSIDs (Wi-Fi 6, HUAWEI WiFi AX3 router - dual core variant) and recently Quest 2 very often loses connection after a moment of Beat Saber play via Virtual Desktop.

After disabling and re-enabling Wi-Fi, it will reconnect and work fine until reboot (I completely turn the Quest off when not in use).

m_c3
Level 3
This definitely has to be an issue with the headset I have connected to three separate Wi-Fi routers including a Netgear nighthawk which connects to everything I have flawlessly. The 5ghz connection just randomly quits. Has anyone gotten a response from Oculus regarding a service ticket with any answers at all?

BILLYBOBERTJOE
Level 2
... I keep getting kicked out of the casting. I cast my quest 2 to my iPhone 11. It says slow connection, then quits. Also I can’t change the headsets WiFi from the phone. I factory reset it and it still happens. please FIX THIS OCULUS!!!!!!!!!!

wilza7
Level 5
i don't think oculus R&D have given oculus support any sensible answers to offer.  so random rubbish is what they seem to come up with.  we wait and hope for a new build with better wifi interop.  in the mean time its kinda of down to luck with what wifi kit you have any if the quest works with it a bit, or at all!

SolidRustle
Level 2
ive discovered i have a stuck white pixel in the middle of the right lense so now im returning the headset to amazon, theyre out of stock so I cant get the replacement just yet, will report back once i have the new headset if the problem still persist. 

SolidRustle
Level 2


ive discovered i have a stuck white pixel in the middle of the right lense so now im returning the headset to amazon, theyre out of stock so I cant get the replacement just yet, will report back once i have the new headset if the problem still persist. 


update to this, I just got my replacement headset from amazon and the issue is exactly the same, nothing to do but wait for oculus to fix this issue in their update now.. on the brightside I eneded up with a sharper headset with no dead pixel (for now) 

3dguy
Level 3
I just purchased a quest 2 and I'm having the same problem. I checked it against my quest 1 and it's not having any problems. So it's definitely not a problem with my router. How widespread is this issue? Is anything being done to address it? Like a firmware upgrade to fix it!

wilza7
Level 5
anyone got a view about v25 fixing any of this?  not gotten around to trying yet.  seems like oculus/fb only list new features in the release notes.  nothing about bug fixes.  bugs never happen! 

andreasgman
Level 2

Here is another workaround similar to the mobile phone hotspot solution mentioned earlier......

 

Connect an old laptop (or PC) directly to your router via ethernet cable.  Now enable a Mobile (Wifi) hotspot on the laptop/PC. (See link below on setting up a wifi hotspot).  Now you can connect the Oculus Quest/Quest 2 to the Wifi hotspot you just setup. 

 

https://support.microsoft.com/en-us/windows/use-your-pc-as-a-mobile-hotspot-c89b0fad-72d5-41e8-f7ea-...

 

Note that the connection of the quest to the laptop/PC will be either 2.4Hz or 5GHz depending on the wifi chip in the laptop/PC.

 

Have fun.

 

'The Boo'

Are you still having these issues? My issue sounded the most similar to the way you described it. I don't know if mine is dropping every 10 minute or not, but when it does drop (which is pretty frequent) it will reconnect after a few seconds.