cancel
Showing results for 
Search instead for 
Did you mean: 

Quest 2 stuck to 72 hz after oculus software update tonight

Frankalexandre
Level 4

Oculus software updated and now even after changing the frequency to 80 or 90 hz it is stuck to 72 hz in games. I have tried to reboot the device, change cable, reboot system....nothing works, it still stuck to 72 hz. With Virtual Desktop wireless it works fine at 90 hz.

45 REPLIES 45

Mio.SuperTramp
Level 2

I tried and it really works!!! I can finally play beat saber with 90hz QAQ
But I didn't find the option in general, you should go"settings" - "Beta"- then disable the public test channel
Then you have to connect your quest 2 to update (downgrade?) your hardware

The problem still exists. Oculus software just updated and I got 72hz, thank you FB. Wasnt subscribed for betas at all.

Wow, they released it like this?! Pathetic. I've reported the bug at least three times with each incremental update of the betas. Clearly the PC side of things is an abandoned platform for Oculus and the development focus has gone to minimums.

Seems so I just got the quest 2 a couple of months ago. Looks like I will be selling it off sooner than i thought.

ThePixelCowboy
Level 4

I also reported this bug. How they pushed it out is beyond me. 

Frankalexandre
Level 4

Yeah, we're waiting for a possible 120 hz update and now we got downgraded to 72 hz.

Neimos
Level 3

If you are one of those getting stuck to 72hz, I found a workaround to make it work properly.

 

Step 1

Go to the Oculus web and download the Oculus Software.

 

Step 2

In you PC open  -  "Star Menu",  "Settings",  "Update and Security",  "Windows Security",  "Firewall & network",  "Advanced Settings" (it might ask for admin permission, accept).

 

Once in there select  -  "Outbound Rules",  "New Rule",  "Program (next)",  "Browse (paths are below)",  "Block the connection",  "Mark the three boxes (next)"  and finally give it a name you recognize so you can delete it easily when this is patched officially and click "Finish"

 

Here are the paths, enter each one in a new rule:

%ProgramFiles%\Oculus\Support\oculus-client\OculusClient.exe

%ProgramFiles%\Oculus\Support\oculus-runtime\OVRServer_x64.exe

%ProgramFiles%\Oculus\Support\oculus-runtime\OVRRedir.exe

%ProgramFiles%\Oculus\Support\oculus-runtime\OVRServiceLauncher.exe

%ProgramFiles%\Oculus\Support\oculus-dash\dash\bin\OculusDash.exe

 

Step 3

Go to C:\Program Files\Oculus\Download (change C: if your Oculus software is installed in a different drive) and delete all the contents.

 

Step 4

Open the Oculus software you downloaded in step 1 and click in repair. This will fully reinstall the software and drivers.

 

Step 5

Set your refresh rate to 90hz and choose whatever resolution suits you.

Open whatever game you wanna play in Steam or Oculus via Link and enjoy 🙂

This wont allow the software to be updated until after you remove those rules, so you are safe to play for as long as you wish. I tested all my steam games and they run even better than before (maybe the block is keeping the software from reporting back to Facebook too). Since I only own Steam VR games, I can't tell if this will affect at all Software from the Oculus store, feel free to try and reply to help others.

I dont get the idea, my software is 27, when I repair it, it stays 27... I need to downgrade it to 26 somehow. But I understand the point with the blocking rules.

ps. found version 23 on a forum, it helped.

At the moment of my post, the downloaded version with the install file was 26 which is why is so importan to follow the steps in order and delete everything in the download folder otherwise the updates previously downloaded with re install after the repair.

 

Anyways would you mind sharing the link to the V23 download so others can downgrade?

there is no point in the V23 because you get a constant error about unknown sourses whatever you do.