cancel
Showing results for 
Search instead for 
Did you mean: 

Quest + USB 3.0 cable have worked for months, now Oculus App claims it's USB 2.0 and won't work.

ZimmWisdom
Level 2
I would like to get my Quest + USB 3.0 Cable working again.
Every since December, I had used my Quest + Cable to play Rift games, without issue.
As of 02-24-2020, The Oculus App claims the cable or port is USB 2.0 and won't function.
None of my hardware has changed, only updates to the Oculus App and Quest have changed.

I have been in contact with Oculus Support to try and resolve the issue, I have tried the following (which none has worked):

* Restarted my computer
* Restarted the Oculus App
* Restarted the Quest
* Turned on PTC and updated to it
* Turned PTC back off as it apparently breaks Link support
* Updated the Graphics card drivers (RTX 2070 Super)
* Made sure that all USB ports do NOT have power saver mode on
* Tried every USB 3.0 port on my desktop

Nothing seems to get rid of Oculus' insistence that my USB 3.0 port and USB 3.0 cable are merely 2.0, despite working for months.

What else can I/should I try?
7 REPLIES 7

suppenhuhn
Level 3
Same here...no solution found yet

greetings from bavaria

iTesla8
Level 4
I did update but no such problem.
My Own PC Build: NZXT Source S340 White > Corsair RM1000i > Asus ROG Strix Z270F Gaming > CPU Intel i7-7700K 4.5Ghz > Deepcool Captain120 EX > RAM KHX2400C15/16G | 4pcs = 64GB > Asus GTX1070 Dual O8G > Samsung U32J59xUQ 4K > Realtek High Definition Audio > Intel SSD 760p Series PCIE/NVMe M2.1 1TB > Intel SSD 600p Series PCIE/NVMe M2.2 1TB > AZIO Retro Classic Copper > Razer Mamba Hyperflux = Oculus Quest/Link

ZimmWisdom
Level 2
SOLVED. But I still don't understand.

Since last update I have:

* Factory reset my Quest
* Uninstalled/Reinstalled Oculus Desktop App
* Uninstalled/Deleted left over files/Reinstalled Oculus Desktop App
* Tried Turning PTC on and off again

But this NEXT Step, during setup of the Desktop App, SOMEHOW worked...

* I unplugged my USB-C to USB A adapter from my desktop
* I unplugged the USB-C cable from the adapter
* I rotated the USB C cable 180 degrees and replugged it into the adapter
* I plugged the adapter back into the desktop
* This SOMEHOW worked...

I'm happy, but confused.

DaftnDirect
Volunteer Moderator
Volunteer Moderator
Is it possible something has become slightly damaged during play? either cable or adaptor? I'm wondering if a tug on the cable has bent a pin a little or stressed a core/connection in the cable.

A good thing about USB-C is that it has built-in redundancy, in that the connector pins are duplicated on both sides to allow the cable to be plugged in either way round.

Intel 5820K OC@4Ghz, Titan X (Maxwell), 32GB Corsair Vengeance DDR4, ASRock X99 Taichi, Samsung 500Gb 960 Evo M.2, Corsair H100i v2 Cooler, Inateck KTU3FR-4P USB 3 card, Windows 10 Pro v20H2 (19042.964)

suppenhuhn
Level 3


SOLVED. But I still don't understand.



What versions are you using ( Quest and PC ) ? Cause i got the same issue -> but using a CABLETEX USB-A to C cable. As mentioned it was working until the latest PC update...and nothing helped -> no uninstall, no repair, no nothing :s
greetings from bavaria

OJ_PIMPS0N
Level 2


SOLVED. But I still don't understand.



LOL rotating the USB-C cable also worked for me. Thank you so much for posting the solution. This has been driving me nuts for a while. It was working for months until a couple weeks ago. I reverted back to using my Rift temporarily for development until now.

Sproesser1
Level 2
Rotating the USB cable did not work for me. Any help with this would be great. The cable i was using when the problem started going bad disconnects easily if you move the cable(bad cable). I tried a new cable that is compatible, no fix. I suspect the bad cable messed with my pc hardware and changed an internal setting somewhere.