cancel
Showing results for 
Search instead for 
Did you mean: 

Quest and Quest 2 controllers not detected by Oculus App on PC

pierre.dery.12
Level 2

I have used Link for some time on my older PC and it worked fine. I didn’t use it for the last few month and tried again this week after updating the software on the headsets (Q1 and Q2 since I have both) and the PC. Now the Oculus app does not detect the controllers anymore even if it works perfectly as stand alone. Neither Link nor Air Link will work. At first I saw the controllers not being connected, I removed them in order to try and reconnect but now I just don’t see them at all. 

The problem is the same for both headset/controllers. By the way it works fine on my other PC.

3 REPLIES 3

OculusSupport
Oculus Community Manager
Oculus Community Manager

Hey pierre.dery.12, we're more than happy to help figure out why the app isn't detecting your controllers! Can you tell us what your PC specs are?

pierre.dery.12
Level 2

CPU: i9-9900K

GPU: NVidia RTx 2080 Super

Memory: 32.0 Gb

Windows 10, 64 bits

Any news for me? I’m still working with Sara on my lifted ticket but no result yet.