cancel
Showing results for 
Search instead for 
Did you mean: 

Save Data - Creed Rise to Glory

MikeBrothers001
Level 2

I allowed access to storage. The storage shows some GB of saved data for the game. But when I go back into the game, I hit career and it doesn’t say “continue”. That’s if I exit the game. If I just go to main menu continue is there. 

I’ve tried every way to exit the game and go back to test and nothing works. 

I go to main menu using the left controller key. Once I exit the game the game has to restart and career mode starts at the gym. 

help me out please. Thanks. 

12 REPLIES 12

MikeBrothers001
Level 2

OculusSupport
Community Manager
Community Manager

Hello, MikeBrothers001. We see you mentioned having issues with the game Creed: Rise to Glory and the storage space; don't worry, we've got your back. We will have you back in the boxing ring in no time. Can we suggest restarting the device here, checking the device's storage to ensure you have enough space, and also checking the WiFi to ensure you have the best coverage?

 

If you are still having problems, please let us know so that we can look into it further for you.

@OculusSupport 

 

thank you for responding. I did the above and verified storage space as well as my wifi connection - still not able to save content. 

Thank you. 

Thanks for keeping us in the loop, we can suggest just one more thing to ensure this is resolved.

 

Can you check and see if any other app is having trouble saving data?

Try to uninstall the app and reinstall it.

 

In some cases, some apps and games require you to properly exit the content you're playing before it can save. Instead of quitting the app from the Quest menu return to the main menu on the game or app that is being used and then exit.

 

We hope this info helps! You can also reach out to the developer for any game-specific questions you may have.

@OculusSupport 

 

thank you. As I stated in my first post, I already tried exiting from the main menu. I’ll will see if other applications can save data and report back. 


how do I get in touch with the develops of the game?  Also, uninstalling and reinstalling, will that delete my purchase? 

 

Hey there again. To get in touch with the developers you can reach out to them HERE.

Your account will remember your purchase history. You will not have to purchase the game again, just re-download it.

j.s.nunho
Level 2

Hi @MikeBrothers001 !

I have the same issue... did you find a solution that you can please share?

RRoundhouse
Level 2

@OculusSupport 

 

Sadly... I have  had the same issue. I allowed access to storage at the start,  and only exit the game from the main menu, but it refuses to save progress. I even tried deleting the app and completely reinstalling, then deleted data... reset all settings... nothing fixes the issue.

No other game in my library seems to have this issue currently.

Hello @RRoundhuse! We understand you're having issues with Creed Rise to Glory. Your overall gaming experience in the Meta Quest VR world is very important to us and we're not going to let a minor glitch ruin it.

 

Can you tell us; did you purchase the app from Meta or Steam? And are you playing PCVR or standalone?

 

Looking forward to your response!