cancel
Showing results for 
Search instead for 
Did you mean: 

Solution for three white dots when trying to connect to AMD Ryzen 9 IGPU w/ RTX 3XXX laptop DGPU

Heli-Mech
Level 2

I have an Oculus Quest 2 and Asus ROG Strix G17 G713 laptop w/ AMD Ryzen 9 5900HX cpu/igpu and RTX3060 dgpu. 64 GB DDR4 CL22 3200 RAM.

 

I couldn't get Oculus  Air Link or Link to work.

 

Just three white dots forever loading nothing. So disappointing.  😕

 

Saw some comments online about issues with RTX3XXX laptops. 

 

I combed the internet and tried everything. Changing default program settings in Windows for GPU selection changed nothing. 

 

At first I just disabled the igpu in Device Manager and Link would kind of work. VR performance was unplayable. Stuttering beyond anything useable. 

 

What eventually worked for me was:

 

1) Boot PC to Desktop.

2) Disable igpu (not dgpu) in Device Manager.

3) Load Oculus PC App.

4) Enable igpu in Device Manager. 

 

Good to go. 👌

 

Instant Half-Life Alyx, Asgard's Wrath, Lone Echo, Boneworks, Onward, Battle Sister, Demeo = Heaven. 

 

Huge relief after seemingly trying everything. I hadn't thought to re-enable my igpu after loading Oculus. That was the key.

 

When/if Oculus Tray Tool is loaded has no effect on this process. So if it loads first don't sweat it.

 

You can plug and unplug the Quest 2 at will afterwards.

 

Only need to repeat the process if you reboot your PC. 

 

Hope this helps someone else.

 

Ps - I have wicked fast WiFi 6 internet w/laptop connected directly. Air Link doesn't perform as well as Link for me. 

1 REPLY 1

Bigstyl3
Level 2

 happend to me only when i had an external sound(Sound blaster) card pluged in my desktop ..and yeah that 3 dots wouldnt go anywhere unless i unplug the sound card