cancel
Showing results for 
Search instead for 
Did you mean: 

Steam VR games running extremely badly.

dryhiow
Level 3

As the title says any time I try to play a steam vr game it runs horribly, this issue only occurs with steam vr games and none others. The odd thing about it is steam vr runs perfectly smooth and the lag only occurs with the actual games. I had previously used virtual desktop to play games, and they worked perfectly when I did, but due to a recent incident we had to downgrade our router and I can no longer use it. The only pc vr games I have are currently all on steam, so it is dire that I use steam. If you couldn't figure it out already I am using link.

1 ACCEPTED SOLUTION

Accepted Solutions

dryhiow
Level 3

I ended up finding a fix for this my self, turns out your computer is trying to use the integrated graphics card instead of your dedicated one. To fix this first you need to set the preferred GPU in Nvidia control panel to "Auto-select" apply that. Second go to windows graphics settings, easiest way to get there is just hitting the windows key and searching for "Graphics settings", once you are there scroll down to "Choose an app to set preference" click browse. After that a windows comes up in file explorer, from there go to your C: drive>Program files(x86)>Steam>Steamapps>Common>(the game your wanting to play) and in said folder find the .exe file, click on it, and click "add" on the bottom right. Once you have done that, find your recently added game below the browse button, click on it, then click options, and select high performance then save.

 

Once you have done all of that it should run smoothly, depending on your how good your GPU is, unfortunately you will need to do this for every game.

View solution in original post

1 REPLY 1

dryhiow
Level 3

I ended up finding a fix for this my self, turns out your computer is trying to use the integrated graphics card instead of your dedicated one. To fix this first you need to set the preferred GPU in Nvidia control panel to "Auto-select" apply that. Second go to windows graphics settings, easiest way to get there is just hitting the windows key and searching for "Graphics settings", once you are there scroll down to "Choose an app to set preference" click browse. After that a windows comes up in file explorer, from there go to your C: drive>Program files(x86)>Steam>Steamapps>Common>(the game your wanting to play) and in said folder find the .exe file, click on it, and click "add" on the bottom right. Once you have done that, find your recently added game below the browse button, click on it, then click options, and select high performance then save.

 

Once you have done all of that it should run smoothly, depending on your how good your GPU is, unfortunately you will need to do this for every game.

View solution in original post