cancel
Showing results for 
Search instead for 
Did you mean: 

The Official Oculus Link cable is not working for me. Anyone else have this issue?

TuSwab
Level 2
My third-party cable works perfectly fine but I cannot enable Oculus Link with the $80 cable that I just received. The oculus software will detect that the quest is plugged in to my USB-C port, yet I get no pop up to turn on Oculus Link and It wont work manually either because the quest doesnt know its plugged in. 

I've submitted 2 support tickets with no response. I've also posted on reddit and I found that there are other users with this exact problem. They have also submitted tickets with no response. I'm about to send it back for a refund, but I really want this cable to work.
137 REPLIES 137

Marirari89
Level 3
My official oculus link cable works sometimes if I wiggle it a little, but it only gives speeds of about 2.5 gbps at best, which is not what it is supposed to get as I understand it. For me games lag very much when playing with the official link cable. Thankfully, virtual desktop works very well in my appartment.

havedeg
Level 2
Any solution exists or not?

MoleUK
Level 3
Same problem here, going through support and jumping through all their hoops but it refuses to pick up the cable as usb 3 now.

Robomiller444
Level 2
I went through a lot  of issues with this cable. Quest 2, genuine link cable bought from Best Buy in December.
X570 PRO mother board. USB C would work sporadically. Ordered a usb c to a adaptor. Worked but was only getting 45 frames on Half Life Alyx. Bought this USB 3.2 PCI card on ebay and it worked like a charm...



It might not let me post the link because I am new. If you search on Ebay it's the rosewill usb pci 3.2 card 29.99 or so.
Fixed all issues, everything connects instantly. Now I get 90fps on Alyx. Charges the unit while in use.
Also, I was able to select "yes" on share data prompt without dropping the connection, now more details load on the oculus PC app.

Hope it helps. Won't help people with laptop issus.

Mykale29
Level 2
When I try to connect my Oculus Quest 2 to my gaming desktop (GPU 1080TI} with the Link cable, I get a PC not detected message. The Oculus App on the desktop will go thru the setup process and show Green and that the Quest 2 is connected to the App however it will disconnect and reconnect periodically. There is no message to enable Link. If I try to run the USB test from the Oculus App it fails. When I manually try to enable the Link cable through the headset I get a PC not detected message. I also have an Alienware gaming laptop that the Link cable connects to and is rock solid. I have tried different USB ports and even acquired a USB C to A adapter to try a work around to no avail.

Astral451
Level 2

I have had similar issues as above, connection issues and such.  On my PC I have a GTX 970 ( min spec for oculus ) and I have a PCI-E USB3.0 adapter card.  This card has a USB-C port so I can connect directly.  The behavior I get is such.  When I plug in the Link Cable ( official oculus ) the head set will prompt with "Accept Device" and then 1 second later disappear, back to Home, then 1 second later prompt again. It will keep doing this as long as it's connected.  I was able to use a shorter USB 2.0 cable to get the initial connection, but the sustained USB3.0 was not working.  

I have a support ticket open with Oculus support and we did lots of logging and updates and reinstallation of software to rule out various things.  Ultimately none of it fixed the issue.  As of 4 days ago I had an RMA number ( return to manufacturer code ) and sent it off next-day-air to Oculus support on their dime.  I haven't heard anything from them since that last UPS delivery label was printed and sent off.

I'm unsure if it will be a credit or a replacement, but as of today no news.  I'm hopeful they will do right by this situation.  I supposed the easiest is for them to credit and just let me get Virtual Desktop which I have heard is pretty good, just not quite the speed of the USB3.0 would be.

Hi,

 

The fix for me was to disable the Air Link option in the headset.

 

Hope this helps.

TarmoP
Level 2

We've purchased Oculus Quest 2 with usb link cable and tried it for multiple days. Usb link connection has bad connectivity and there is nothing user can do about it. We've decided to return whole product back to store.


To Oculus company - would it be possible to fix this issue permanently by designing better connectivity connection between Oculus Quest 2 and usb link cable ? 

My son at the moment is searching for alternatives, like DecaGear - but I suspect it's not yet released and no guarantee that it will be better.

 

I would prefer to have Oculus Quest 2 fixed and released - I would re-buy newer fixed version.