Showing results for 
Search instead for 
Did you mean: 

Unable to connect Oculus Quest 2 with Iphone app

Level 2

Hello, I've recently got a quest 2 and I'm having difficulty with 2 things:


1) Connecting to the ios app




2) casting to nvidia shield (or to a samsung smart tv)


With problem 1, I'm opening the Oculus app (latest version - updated this morning!), opening the 'devices' menu - the quest 2 picture appears and I see multiple headset settings options - but at the top left it's flashing 'Not found' and the button below the quest image flickers between 'Searching....' and 'Connect' repeatedly.


I've tried clicking the + button to add a new device, when i do this (select quest 2, continue past messenger alert) - it then says "Pairing your quest 2 - your pairing code was automatically detected' - but then fails to connect and i get an error appear:


Unable to connect to your headst

We can't connect to your headset. Please try the troubleshooting steps below:

- Make sure that your headset is pwoered on, bluetooth is on and your phone is next to your headset

- check that your headset screen is lit up (etc etc)

- try turning bluetooth off and on again

- check that your phone is connected to the internet


I've checked all of this I think - assuming the bluetooth points relate to the phone rather than the quest ? (I cant find an option to disable bluetooth on the quest) - also both devices are on the same wifi network.



As for the second issue with the casting - From within the OQ2, if i click share, then cast - the shield appears, but throws an error after the connection request is sent.... the samsung smart tv doesnt even appear in the list of devices to cast to? (usually I can cast from my phone to either the TV or the shield and both are fine) - again, all are on the same wifi network.


Does anyone have any ideas on how i could possibly fix this please?

Is there a way to factory reset the quest 2 without the app being connected?






Volunteer Moderator
Volunteer Moderator

It sounds like it could be a problem with Bluetooth in the Quest itself… unfortunately that’s not something you have the ability to fiddle with. Have you tried doing a full shut-down and reboot of the headset? The next option would be a factory reset, which you can do directly within the headset, but you’ll lose your progress in any games that don’t use cloud saves (many don’t). This support article describes the process to factory reset the headset without the app. Be warned though, if the factory reset doesn’t fix it, you may not be able to set up the headset at all. It might be worth first trying to connect with the app on another phone or iPad if you can.

i7 5820K @ 4.25GHz | RTX 3080 Ti FTW3 | Gigabyte GA-X99-UD4 | Corsair DDR4 3000 32GB | Corsair HX 750W
SSDs: Intel 660p M.2 2TB, 3x Samsung Evo 1TB | Startech PCIe 4x USB 3.0 | Startech PCIe 2x USB C 3.1 gen2

Thanks - after doing a factory reset using the power and volume down buttons, I managed to pair the OQ2 with the phone and was able to cast to the app! Making progress!


I’m still not able to cast to the shield, but that may be a shield issue possibly… and the smart tv doesn’t even get listed as a cast device!…. I’m going to take it with me later and try it on with someone else’s tv / an actual chromecast and see how I get on 👍