cancel
Showing results for 
Search instead for 
Did you mean: 

Wifi disconnects when connecting to PC over USB

phobos2077
Level 3

Whenever I connect Quest 2 to a PC with a USB cable (that I use for Oculus Link), Wifi disconnects immediately and couldn't re-connect. It says "check your password" or such. Obviously the password is correct because as soon as I disconnect USB, Wifi happily connects again to my router. Wifi works (and always worked) without a hitch on multiple mobile devices from the same router.

 

Some facts:

- Latest stable Oculus software is installed on both PC and headset.

- OS: Windows 10.

- Router: Zyxel Keenetic Omni.

- Wifi is setup as 2.4GHz with WPA2-PSK security.

- NetSpot says signal is good for this router.

- In router web interface in currently connected devices I can see my Quest 2 being connected for brief periods when it tries to authorize in Wifi settings window on headset.

- This issue doesn't seem to happen when I use USB 2.0 slot on the front of my PC case.

- All USB slots on the motherboard back panel are 3.0 or 3.1 - they all trigger Wifi to disconnect.

- I have adb installed with Oculus debugging drivers (though this happened already before I installed these drivers).

 

Based on this my guess there's some software issue happening on the headset itself, related to Oculus Link maybe?

2 REPLIES 2

OculusSupport
Oculus Community Manager
Oculus Community Manager

Hey phobos2077! We see that your Wi-Fi seems to disconnect when you connect to a PC with a USB cable and we have a couple few questions about this:

 

  • Are you using the official Oculus Link cable?
  • Have you tried using a different cable? 
  • Are both devices connected to the same Wi-Fi connection?


If you find that you have the option to connect your devices to 5G, connect to it and make sure both devices are on the same connection. If you continue to experience issues, please respond with the requested information so we can help you find a fix. As, always we are happy to help. 

 

 

- No, I'm using a third party USB 3.0 (Type-C -> Type-A) cable. It works fine for Oculus Link gaming and passes the USB test in the Oculus app (reports bandwidth of 2.5Gbps).

- I have tried connecting to the power socket with a normal USB 2.0 cable - no issue. Don't have any other USB 3.0 cable to test connection to PC.

- By both devices you mean Quest 2 and mobile phone? Then yes. My PC is connected to the same router by wire (RJ-45).

 

My router doesn't support 5G.

 

Confusingly, this issue doesn't seem to happen sometimes. After restarting my PC today I couldn't reproduce Wifi connection failure with the same cable/setup which did it yesterday. Really feels like a software issue. I'll test this more.

 

Update: on the same Windows session: plugged my Link cable, entered Oculus Link, then exited it. Then opened SideQuest. After that wifi disconnected and couldn't reconnect. I tried switching again to USB 2.0 Type-C->Type-C cable - no wifi issue. Tried repeating the same steps (open Link, exit, open SideQuest on PC) - no issue. Then re-connected Link cable again... No issue! Repeated the same steps (enter/exit Link, open SideQuest) - no issue. Very strange.