cancel
Showing results for 
Search instead for 
Did you mean: 

faulty oculus quest 2 remote

RossyBoy_06
Level 2

Can anyone help? My right controller has stopped working. I have tried taking out the battery for 3 minutes and then putting it back in but nothing seemed to work. I have also tried unpairing and pairing the controller on the oculus app and that didn't work either. I've also replaced the battery with a new one and it still doesn't work.

2 REPLIES 2

rockye64
Level 3

I had this same issue a few months back.  I opened a support ticket and Oculus sent me a replacement controller.  I will add that I still have issues with the replacement right controller, but I'm now able to fix the issue by reseating the battery.  Hope this helps!

OculusSupport
Oculus Community Manager
Oculus Community Manager

Hello there, we know how frustrating this can be, thank you for trying those trouble shooting steps. Please go ahead and get in contact with Oculus. An agent will be happy to assist you with this issue in order to get you back to gaming. You can also choose the live chat option to get in contact right away!