cancel
Showing results for 
Search instead for 
Did you mean: 

quest 2 link to pc issues

Salty_Vid
Level 2
I recently bought the quest 2 and bought the Anker VR cable to be able to play steam VR games on my laptop. When I try to connect the quest to my laptop, it boots up and everything, however, the image is a mess and is tough to look at. My movements are very slow, and when I turn my head, a black screen appears from the sides. The cable test thing on the oculus app said the cable is fine, and I made sure my laptop is within the specs. I updated my drivers, USB and graphics card, and made sure I'm running the latest windows. oh, and Steam VR doesn't recognise the quest 2 when It's connected, even when I'm in the quest hub thing. can someone please help me?
My laptop is running a GTX 1660Ti, Ryzen 7 4800H, and 16gb of RAM.
6 REPLIES 6

PITTCANNA
Level 13
Do you have the app installed? Because you need to access steam via the oculus desktop.  You also need to enable outside sources.

crxefx
Level 5
I had pretty much the same experience when trying link the other day. I was going to ask if anyone else had this problem. Instead I just unplugged and switched to virtual desktop like I normally use and had no problem at all.

Salty_Vid
Level 2

crxefx said:

I had pretty much the same experience when trying link the other day. I was going to ask if anyone else had this problem. Instead I just unplugged and switched to virtual desktop like I normally use and had no problem at all.


I wish I could just use virtual desktop, but my internet is hot garbage so that's not viable for me sadly.

Salty_Vid
Level 2

PITTCANNA said:

Do you have the app installed? Because you need to access steam via the oculus desktop.  You also need to enable outside sources.


yes. I have the app on my laptop, and I have outside sources enabled. it's still a slow, laggy mess and I don't know how to fix it.

yod_alemu
Level 2
Did you ever find a fix? I'm currently struggling with this right now!

Alex_fr_62
Level 2
Hello,

Same issue for me so sad
My config new Portable TUF GAMING A17  win 10, Ryzen7, nvidia 1660ti, 16 g RAM
i have downgraded my Ryzen better connection for the cable but still lag (A non official Cable but connected at  2.6Ghz).

Virtual desktop seems to work fine but not enough wifi connection for me..(tried ethernet... same problem)
I
think the problem is the oculus application because when i play asgard
wrath that lag but when i play gta5 (full setting with virtual desktop
no problem).

So desappointed.. pc+oculus+accessories+game+appli and  i have to wait for playing such game as asgard or alyx.

Hope a great update for christmas!! o

Happy Christmas!