cancel
Showing results for 
Search instead for 
Did you mean: 

"Restart Computer" Can't install Oculus app...

DrigoNuiyaki
Level 2

Got my Quest 2 yesterday, then went to install the oculus app, it downloaded the 5GB of files, and then got stuck halfway through the install. I checked task manager and it said suspended, so I resumed it, and it went to about 3/4 of the way through installation and says "Restart Computer - There was an error installing oculus software"


Here's where the fun begins.. I tried resorting to looking everywhere I could think for info on the situation. I've tried deleting all oculus files in Appdata, temp, and program files several times, that didn't work. I tried uninstalling literally all c++ applications, didn't work (and now I'll have to find them somewhere). I tried installing to a different drive, didn't work. I tried making a whole new administrator user to do a clean installation, DIDN'T WORK. 


I checked the appdata/local/oculus install txt file, and the only thing it says is after it gives me the error, the file says "Exception deleting 'C:\Users\Seth\AppData\Local\Temp\OculusSetup-b983bcc9-df28-43a9-8e13-fe95c6e13bb5':
System.UnauthorizedAccessException: Access to the path 'DaybreakNative.dll' is denied." Which is strange, given I manually tried to make all access points for the setup fully accessible and ran the setup application as administrator as well as (in a different try) moving the setup exe INTO the program files folder!

 

 

I really need help with this issue and I hope I was descriptive enough.

3 REPLIES 3

OculusSupport
Oculus Community Manager
Oculus Community Manager

Hey DrigoNuiyaki, we wanted to jump in here and let you know we appreciate all of the steps you've tried so far to get the Oculus App working on your PC. We're here to help resolve this for you and would highly recommend opening up a support ticket with us here so that we can help you further. 

 

In order to speed up the process, we do ask if you can attach logs from your system to your initial support contact so that our team can review them immediately. In order to collect these logs, please do the following:

1. Open the run window (Windows key + R)
2. Enter and run: C:\program files\oculus\support\oculus-diagnostics\OculusLogGatherer.exe
3. Wait for the executable file to pop up
4. Select logs for the last 24 hours
5. Wait for the log collection to finish. It should pop up a Windows Explorer window at the location of your newly collected logs.
6. It automatically generates a zip file and copies the zip to the clipboard so you can paste it to your desktop
7. Attach this zip file to your next support response

 

Please also either link this thread or include this message in your ticket that way we'll be able to fully understand the situation you're experiencing. We look forward to hearing from you so that we can assist you on this as soon as possible! 

OculusLogGatherer.exe does not exist since the installation was broken, and a 2 hour conversation with an oculus support specialist had me try the same things I've done already to no success.

 

From reviewing the setup log file, it seems the reason it keeps stopping is because the installer has no access to delete some of the files in the temp folder. Many others have the issue but I've found no remedy in their responses they got.

OculusSupport
Oculus Community Manager
Oculus Community Manager

Hey, thanks for taking the time to troubleshoot this issue on your own. We'd definitely like to take a further look into this, can you please click here to submit a ticket and include your Oculus Setup Logs? Much appreciated.