cancel
Showing results for 
Search instead for 
Did you mean: 

stuck on 36,40 and 45 fps with a more than a vr ready pc

hello I hope someone can help me because oculus support couldn't really help me. So I have an oculus quest 2, 128gb and I play with oculus link and when I have my headset set to 90hz I get 45 fps max and even if i lower it to 80 hz I get 40 fps and same with 72 hz i can't go higher than 36 fps so as if it's cut in half. I have only tested steam games like assetto corsa, assetto corsa competitzione, project cars 2 and dirt rally 2.0 and they all can't go higher then 45fps even if I turn the settings to the lowest, just dirt rally I seem to get a constant 90 fps in the menu and in game I go max t'ill 50 fps. and also in assetto corsa right at the second I start the race i'm at 250-200 fps but a second later it drops back to 45 fps. it's weird and annoying because I know my pc can get way more than 45 fps because I have a rtx 2060,  i7-8700, 16 gb ram, 480 SSD, 3T harddrive and I play with oculus link and yes it's plugged to a 3.0 usb port. 

 

thanks in advance, 

1 ACCEPTED SOLUTION

Accepted Solutions

TomCgcmfc
Level 15

With SteamVR make sure you do not have Motion Smoothing enabled.  With Oculus make sure you disable ASW.  Both of these half your refresh rate FPS if your pc cannot meet your refresh rate FPS.

 

Google how to turn these on/off.  You will then be able to see what your pc is capable of and adjust refresh rate and graphics settings accordingly.  

With a rtx2060 I’d recommend starting off with 80Hz refresh rate on your oculus desktop app device graphics settings and the encoding res slider at the recommended point (probably 1.0x).

9 9900k, rtx3090, 32 Gb ram, 1tb ssd, 4tb hdd. xi hero wifi mb, 750w psu, Q2 w/Air Link, Vive Pro

View solution in original post

4 REPLIES 4

TomCgcmfc
Level 15

With SteamVR make sure you do not have Motion Smoothing enabled.  With Oculus make sure you disable ASW.  Both of these half your refresh rate FPS if your pc cannot meet your refresh rate FPS.

 

Google how to turn these on/off.  You will then be able to see what your pc is capable of and adjust refresh rate and graphics settings accordingly.  

With a rtx2060 I’d recommend starting off with 80Hz refresh rate on your oculus desktop app device graphics settings and the encoding res slider at the recommended point (probably 1.0x).

9 9900k, rtx3090, 32 Gb ram, 1tb ssd, 4tb hdd. xi hero wifi mb, 750w psu, Q2 w/Air Link, Vive Pro

View solution in original post

hi thanks for responding. It actually worked thank you, now i can get a steady 72 fps with low to mid settings. But still I do think that my pc can give more than 72, do you have any tips or advice to bump up my performances ?

 

thank you,

@yassine_akharraz  The only way to bump up your performance is to either buy a better GPU (a rtx3070 or better) or simply lower your Graphics settings (including super sampling and in-game settings).  Sorry if this seems too obvious, lol!

9 9900k, rtx3090, 32 Gb ram, 1tb ssd, 4tb hdd. xi hero wifi mb, 750w psu, Q2 w/Air Link, Vive Pro

There's another way to cheat some performance out of it. Read my responses in this post.

https://forums.oculusvr.com/t5/Oculus-Quest-2-and-Quest/Quest-2-Connecting-without-a-USB-C-port/m-p/...